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About This Guide
This manual will see you through your initial contact with . Check out the various parts
of this manual to learn how to install, use and enjoy your system.

Installation and Setup
Guides you through the installation process and the basic configuration of your
system. Introduces YaST, the central tool for installation and configuration of your
system. Learn how to set up or modify key components of your system and how
to connect to the internet.

Basics
This part mainly addresses to users changing to Linux from other operating
systems. It introduces basic Linux concepts such as the user concept, the structure
of the file system and access permissions for files and directories. An introduction
to the shell is also provided, although you hardly ever need the command line to
interact with your system nowadays.

Help and Troubleshooting
Provides an overview of where to find help and additional documentation in case
you need more information or want to perform specific tasks with your system. Also
find a compilation of the most frequent problems and annoyances and learn how
to solve these problems on your own.

This manual documents milestone 7 of 11.4.

Many chapters in this manual contain links to additional documentation resources.
This includes documentation that is available on the system as well as documentation
available on the Internet.

For an overview of the documentation available for your product and
the latest documentation updates, refer to http://www.novell.com/

documentation/opensuse114  or to the following section.

1 Available Documentation
We provide HTML and PDF versions of our books in different languages. The following
manuals for users and administrators are available on this product:

Start-Up (page 1)
Guides you step-by-step through the installation of from DVD, or from an ISO
image, gives short introductions to the GNOME and KDE desktops including some
key applications running on it. Also gives an overview of LibreOffice and its modules
for writing texts, working with spreadsheets, or creating graphics and presentations.

Reference (↑Reference)
Gives you a general understanding of and covers advanced system administration
tasks. It is intended mainly for system administrators and home users with basic

http://www.novell.com/documentation/opensuse114
http://www.novell.com/documentation/opensuse114


vi Start-Up

system administration knowledge. It provides detailed information about advanced
deployment scenarios, administration of your system, the interaction of key system
components and the set-up of various network and file services offers.

Security Guide (↑Security Guide)
Introduces basic concepts of system security, covering both local and network
security aspects. Shows how to make use of the product inherent security
software like Novell AppArmor (which lets you specify per program which files the
program may read, write, and execute) or the auditing system that reliably collects
information about any security-relevant events.

System Analysis and Tuning Guide (↑System Analysis and Tuning Guide)
An administrator's guide for problem detection, resolution and optimization. Find
how to inspect and optimize your system by means of monitoring tools and how to
efficiently manage resources. Also contains an overview of common problems and
solutions and of additional help and documentation resources.

Virtualization with KVM (↑Virtualization with KVM)
This manual offers an introduction to setting up and managing virtualization with
KVM (Kernel-based Virtual Machine) on . Also shows how to manage VM Guests
with libvirt and QEMU.

Find HTML versions of most product manuals in your installed system under /
usr/share/doc/manual  or in the help centers of your desktop. Find the
latest documentation updates at http://www.novell.com/documentation
where you can download PDF or HTML versions of the manuals for your product.

2 Feedback

Several feedback channels are available:

Bugs and Enhancement Requests
To report bugs for a product component, or to submit enhancement requests,
please use https://bugzilla.novell.com/ . For documentation bugs,
submit a bug against the component Documentation for the respective product.

If you are new to Bugzilla, you might find the following articles helpful:

• http://en.opensuse.org/openSUSE:Submitting_bug

_reports

• http://en.opensuse.org/openSUSE:Bug_reporting_FAQ

User Comments
We want to hear your comments and suggestions about this manual and the other
documentation included with this product. Use the User Comments feature at the
bottom of each page in the online documentation or go to http://www.novell
.com/documentation/feedback.html  and enter your comments there.

http://www.novell.com/documentation
https://bugzilla.novell.com/
http://en.opensuse.org/openSUSE:Submitting_bug_reports
http://en.opensuse.org/openSUSE:Submitting_bug_reports
http://en.opensuse.org/openSUSE:Bug_reporting_FAQ
http://www.novell.com/documentation/feedback.html
http://www.novell.com/documentation/feedback.html
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3 Documentation Conventions
The following typographical conventions are used in this manual:

• /etc/passwd : directory names and filenames

• placeholder: replace placeholder with the actual value

• PATH: the environment variable PATH

• ls, --help: commands, options, and parameters

• user: users or groups

• [Alt], [Alt] + [F1]: a key to press or a key combination; keys are shown in uppercase
as on a keyboard

• File, File > Save As: menu items, buttons

• Dancing Penguins (Chapter Penguins, ↑Another Manual): This is a reference to
a chapter in another manual.

4 About the Making of This Manual
This book is written in Novdoc, a subset of DocBook (see http://www.docbook
.org ). The XML source files were validated by xmllint, processed by xsltproc,
and converted into XSL-FO using a customized version of Norman Walsh's
stylesheets. The final PDF is formatted through XEP from RenderX. The open source
tools and the environment used to build this manual are available in the package
susedoc that is shipped with .

5 Source Code
The source code of is publicly available. To download the source code, proceed
as outlined under http://www.novell.com/products/suselinux/

source_code.html . If requested we send you the source code on a DVD. We
need to charge a $15 or €15 fee for creation, handling and postage. To request a DVD
of the source code, send an e-mail to sourcedvd@suse.de [mailto:sourcedvd@
suse.de ] or mail the request to:

  SUSE Linux Products GmbH
  Product Management
  
  Maxfeldstr. 5
  D-90409 Nürnberg
  Germany
 

http://www.docbook.org
http://www.docbook.org
http://www.novell.com/products/suselinux/source_code.html
http://www.novell.com/products/suselinux/source_code.html
mailto:sourcedvd@suse.de
mailto:sourcedvd@suse.de
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Installation Quick Start

Use the following procedures to install a new version of 11.4. This document gives a
quick overview on how to run through a default installation of .

1 Welcome to

For more detailed installation instructions and deployment strategies,
see the documentation at http://www.novell.com/documentation/
opensuse114/ .

1.1 System Requirements

• Pentium* III 500 MHz or higher processor (Pentium 4 2.4 GHz or higher or any
AMD64 or Intel* EM64T processor recommended)

• 512 MB physical RAM (1 GB recommended)

• 3 GB available disk space (more recommended)

• 800 x 600 display resolution (1024 x 768 or higher recommended)

1.2 Installing

Use these instructions if there is no existing Linux system on your machine, or if you
want to replace an existing Linux system.

1 Insert the DVD into the drive, then reboot the computer to start the
installation program.

http://www.novell.com/documentation/opensuse114/
http://www.novell.com/documentation/opensuse114/
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2 Select Installation on the boot screen and press [Enter]. This loads the
installation program and starts the installation in normal mode.

3 Select the language and the keyboard layout to be used during the
installation and for the installed system.

Read the License Agreement and proceed with Next if you agree. If you do
not agree, press Abort to terminate the installation.
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4 Select New Installation and proceed with Next.

5 Either use the map or the drop down lists for Region and Time Zone to select
the clock and time zone to use in your system. Proceed with Next.
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6 Select the desktop system you would like to use. KDE and GNOME, are
powerful graphical desktop environments similar to Windows, alternative
selections are available when checking Other. Proceed with Next.

7 Define a partition setup for in this step. In most cases a reasonable scheme
that can be accepted without change is proposed. Accept the proposal
with Next and proceed with the installation. Experienced users can also
customize the proposal (Edit Partition Setup) or apply their own partitioning
scheme (Create Partition Setup).
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8 Type your first and last name in the User’s Full Name field, your login name
in the Username field, and your password in the Password field.

For security reasons, your password should be at least eight characters
long and should contain uppercase and lowercase letters and numbers.
Passwords are case-sensitive. Proceed with Next.

By default, the password you enter here is also used for the system
administrator, root. Uncheck the relevant option if you prefer to specify a
different password for root in the next step.

With automatic login enabled, the system boots straight to your desktop
with no authentication at all. If you store sensitive data on your system, you
should not enable this option as long as the computer can also be accessed
by others.
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9 Type a password for the system administrator account (called the root
user). This step is skipped in case you had activated Use this Password for
System Administrator in the previous step.

You should never forget the root password. After you enter it here, the
password cannot be retrieved. It can only be reset with administrative
assistance. Proceed with Next.

10 Use the Installation Settings screen to review your choices as well as some
automatically proposed settings. If necessary, change the settings.

Click Install to proceed. Depending on your software selection you may
have to accept additional license agreements by clicking Accept. Before the
actual installation starts you will see the following screen:

11 Click Install to start the installation.
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12 The installation usually takes between 15 and 30 minutes, depending
on the system performance and the selected software scope. During the
installation you may either view the product presentation, the release notes
containing last-minute information, or the detailed installation log.

13 After completing the installation of all selected software packages and
the basic system setup, the installation boots into the new Linux system,
to perform the automatic system configuration. This routine attempts to
configure your network and Internet access and sets up your hardware. This
process does not need any interaction.
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14 If you have chosen the automatic login function, the desktop directly starts.
Otherwise you will see the login screen. Click on your username, and type
your password in the Password field. Press [Enter] to login.



KDE Quick Start

provides the tools that Linux* users require in their daily activities. It comes with an
easy-to-use graphical environment, the KDE* desktop, that communicates with the
underlying Linux system to access and manage files, folders, and programs.  provides
an integrated suite of applications for a wide range of purposes (office, multimedia,
Internet). The LibreOffice suite is also included, which allows you to edit and save
files in a number of formats. Because the office suite is available for several operating
systems, you can use the same data across different computing platforms.

1 Getting Started

When you start your system, you are usually prompted to enter your username and
password. If you did not install the system yourself, check with the system administrator
for your username and password.

After logging in to KDE for the first time, you see the KDE desktop, which shows the
following basic elements:
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Desktop Folder:  By default, the desktop folder shows the contents of its ~/
Desktop  directory. Whenever you insert a file into this directory, it appears in this
view too.

Desktop Context Menu:  Right-click an empty area on the desktop to access the
context menu for configuring the appearance of the desktop, adding panels or widgets
to the desktop, configuring desktop settings, locking the widgets in their current
position, leaving the current session, or for locking the screen.

Desktop Toolbox:  Move your mouse pointer to the icon in the upper right corner of
the desktop to access the menu that lets you add or lock widgets.

KDE Panel:  By default, the panel of your KDE desktop consists of the Main Menu icon
on the left, further widgets and program icons, and the panel settings icon on the right. If
you hover the mouse pointer over an icon in the panel, a short description is displayed.

2 Starting Programs
Start programs from the Main Menu or from the command line, using a shell or the Run
Command. Additionally, you can start programs from the desktop or the panel by left-
clicking the program icon once.

2.1 Using the Main Menu

To open the Main Menu, click the Main Menu icon in the panel or press [Alt] + [F1].
The Main Menu consists of the following elements: a search function at the top and
several tabs at the bottom, providing quick access to the key functions of the menu.
Additionally, the menu displays your login name and the hostname of your computer.



KDE Quick Start  11

Favorites shows a default selection of key programs for quick access, whereas
Applications shows all applications installed on your system. To navigate through the
menu structure, click an entry and use the arrow icons at the right or the left to switch
back and forth. Computer and Recently Used provide quick access to some frequently
used places, applications, or documents. Leave shows several options for leaving the
session such as logging out, locking the screen (access can only be regained with a
password), shutting down or restarting the computer. Some computers offer to suspend
your session to RAM or disc.

If you often need a program and do not want to dig into the menu structure, you can
integrate the icon into the Favorites tab. Right-click the icon on any of the other tabs
and choose Add to Favorites.

2.2 Using the Run Command Dialog

KRunner is a helper application that lets you quickly start programs. Apart from that, it
offers a search function for finding applications or locations.

Press [Alt] + [F2] to open the Run Command dialog. Type a command, for example,
dolphin. While you are typing, the dialog shows a list of applications or actions that
match your input. Select one of the results or press [Enter] to start the highlighted
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application or action. The command to start the application is often (but not always)
the application name written in lowercase.

KRunner's abilities can also be extended by a huge number of plug-ins that provide
additional functionality. Click the wrench symbol on the left of the input field to explore
the full range of available plug-ins. For example, you can use so-called Web shortcuts
defined in Konqueror to send search requests directly to a search engine without
first opening the browser. For details, refer to Section 8.3, “Configuring Preferences”
(page 25).

2.3 Searching for Programs

Both the Main Menu and the Run Command dialog offer a search function that lets
you quickly start programs even if you do not already know the exact application
name or command. To search for an application, start typing a command or part of the
application name in the Main Menu Search field or the input field in the Run Command
dialog. Each character you enter narrows down the search.

From the list below the input field, choose the application matching your query.

3 Handling Media

If you insert a CD or DVD into your drive or plug in a pluggable device (for example,
a USB stick or removable hard disk), the device notifier widget opens a small window
alerting you to this. It also proposes possible actions, depending on the type of the
device.
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For example, if you plugged in a digital camera, the actions allow you to download your
photos with Gwenview or digiKam. Click the device entry in the widget to access the
available actions. To safely remove the device from your computer, use the icon on the
right side of the device entry.

4 Customizing Your Desktop
You can change the way your KDE desktop looks and behaves to suit your personal
preferences.

4.1 Locking and Unlocking Desktop Objects

Desktop elements can be locked in their current position to prevent them from being
moved around on the desktop. As long as the desktop elements are locked you cannot
add, move, or remove any objects to or from your desktop.

To lock or unlock the desktop elements, click the cashew icon (desktop toolbox) at the
upper right corner of the desktop and select Lock Widgets or Unlock Widgets.

Alternatively, right-click an empty patch on the desktop and select Lock Widgets or
Unlock Widgets.

4.2 Changing Individual Desktop Elements

In the following, you can find some examples of how to change individual desktops
elements.

Procedure 1 Adding Program Icons to the Desktop

To create a link to an application and place it on the desktop or the panel, proceed
as follows:

1 Click the Main Menu button and browse to the desired application.
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2 Right-click and select Add to Desktop from the context menu that appears. If
this menu item is not available, your desktop elements are probably locked.
Unlock them first as described in Section 4.1, “Locking and Unlocking Desktop
Objects” (page 13).

3 To change the icon position on the desktop, left-click the icon and drag it to the
desired position.

To delete an icon from your desktop, right-click the program icon and select Remove
this Icon.

Procedure 2 Adding Widgets to the Desktop or to the Panel

1 To add widgets to you desktop, right-click an empty patch on your desktop and
select Add Widgets.

To add a widget to the panel, right-click an empty patch on the panel, and select
Panel Options > Add Widgets.

If these menu items are not available, your desktop elements are probably
locked. In this case, right-click and select Unlock Widgets first.

2 In the list that appears, select a widget. Use the scrollbar to browse through the
available widgets. To limit the selection of widgets, either enter a search term
in the input field or choose a Category.

3 To make the selected widget appear on the desktop or in the panel, double-
click it and close the dialog box.

To remove a widget from your desktop or panel, right-click the widget and select the
Remove... entry.

Procedure 3 Configuring Desktop Widgets

1 Hover your mouse pointer over the widget until a translucent frame appears
around the widget, showing a number of symbols:

If the frame does not appear, your widgets are probably locked. Unlock them
first as described in Section 4.1, “Locking and Unlocking Desktop Objects”
(page 13).
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2 To change the widget size, left-click the scale symbol in the frame and keep the
mouse button pressed while slowly moving your cursor across the desktop.

3 To rotate the widget in any direction, left-click the arrow symbol in the frame
and keep the mouse button pressed while moving your cursor in a circle across
the desktop. There is a sticky boundary in the horizontal and vertical positions
where you can “clamp” the widget, if you like. Of course, you can also arrange
it in any tilted position.

4 To change the contents, settings, or properties of a widget, left-click the wrench
symbol in the frame. In the configuration dialog box that appears, set the options
according to your wishes.

Procedure 4 Adding and Removing Panels

1 If you want multiple panels on the desktop, right-click an empty area on the
desktop, select Add Panel and choose a panel type from the list.

If these menu items are not available, your desktop objects are probably locked.
In this case, right-click and select Unlock Widgets first.

2 Click the cashew icon at the end of the new panel to access the configuration
options and customize the panel as described in Procedure 5, “Configuring
Panels” (page 15).

3 To delete a panel, right-click a blank space in the panel you want to delete and
select Panel Options > Remove this Panel. requires that at least one panel is
left on the desktop.

Procedure 5 Configuring Panels

You can customize all KDE panels according to your preferences. Applications and
widgets can be added to the quick launch area or the system tray in the main panel or
to additional panels. Panel elements and additional panels can be moved to different
places or be completely removed at any time.

1 To access any options for the current panel, right-click an empty patch in
the panel (or click the cashew icon at the end of the panel) and select
Panel Options > Panel Settings. The panel changes view and shows its
configurations options.

If the menu item and the icon are not available, your desktop objects are
probably locked. To unlock, right-click and select Unlock Widgets first.

2 To move panel objects to a different place within the panel, hover the mouse
cursor over the respective panel object (for example, program icon, pager,
task manager, system tray). The mouse cursor turns into a crosslines-like
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form. Click the object and move the cursor to the desired position in the
panel. Click again to fix it at this place.

3 To enlarge the distance between two widgets, use Add Spacer.... A spacer
widget appears on the right side. Drag and drop it to the preferred place.

4 To change the panel width, click and drag the small arrow icons at the left
and right end of the settings panel. Use the arrow on the left side to set
the panel's position and the arrows at the left side to set the maximum and
minimum size.

5 To change the panel height, click the Height button and move the mouse
cursor to the desired end location.

6 To place the panel at different sides of the screen use the Screen Edge
button. Drag and drop the panel to the preferred location.

7 If you need additional widgets on your panel, add them with the Add
Widgets... button as described in Procedure 2, “Adding Widgets to the
Desktop or to the Panel” (page 14).

8 To remove program icons or widgets from the panel, right-click the unwanted
object and select the menu item to remove the icon or widget.

The icons in the system tray usually belong to applications running in the
background. Therefore you can only remove those icons if you close those
applications (right-click the icon and select Quit).

9 To prevent the panel and widgets from being moved accidentally, use Lock
Widgets.

10 For additional configurations options like alignment and functions (like auto
hide), click More Settings....

11 If all panel changes are according to your wishes, close the panel settings
with the red close button on the right side.

Procedure 6 Changing the Desktop Background

You can change the desktop background to display images, a slideshow, patterns or
colors. It is even possible to use a map of the globe or the weather report as desktop
background.

1 Right-click an empty patch of the desktop and select Desktop Settings. A
configuration dialog appears.

2 In the View section, choose a type from the Wallpaper drop-down list. The
further configuration options depend on the choice of the object to use as
background.

3 For example, to use an image wallpaper:
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3a Set Wallpaper to Image.

3b Define the Positioning of the image.

3c To use one of the available wallpapers, either choose a wallpaper
from the list or click Get New Wallpapers to download additional
wallpapers.

3d To use a custom picture, click Open and select an image file from
the file system.

4 Set the other options in the configuration dialog according to your wishes, and
click OK to save your changes and leave the configuration dialog.

4.3 Modifying System Settings

The System Settings are the central place for users to change the overall appearance
and behavior of many components of the KDE desktop. Start them from the Main Menu
by selecting Favorites > System Settings.

The settings are grouped into different categories. Hover over an icon to see more
details. Performing tasks in some areas of the personal settings requires system
administrator (root) permissions.
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Change the settings as desired. No changes take effect until you click Apply. To discard
changes in the recent view that you have not yet applied, click Reset. To reset all items
in the recent view to the default values, click Defaults.

To get back to the start-up view (showing all categories) again, click Overview at the
top left corner of the dialog. You can also enter a search string at the top of the window
(for example, Screen Saver) to find the category which holds options related to the
search string. Each character you enter in the Search field further narrows the search.

For easier overview of all categories, you can also switch to a tree view by clicking
Configure and selecting another View Style.

5 Applying Desktop Effects

If your computer supports a 3D graphics card with Xgl, you can use graphical effects
like turning your desktop into a rotating 3D cube, enabling translucent or transparent
windows, and zooming in and out of the desktop screen. You can also use other window
effects such as shadows, fading, and transformations. If you do not have a 3D graphics
card, some effects may be disabled or reduce the performance of your system. If the
performance of your system is too low, disable the effects for your current session with
[Alt] + [Shift] + [F12].

To configure effects on your desktop, proceed as follows:

1 Start the System Settings as described in Section 4.3, “Modifying System
Settings” (page 17).
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2 Select Desktop Effects from the Workspace Appearance and Behavior category
and choose Enable Desktop Effects. If your graphic card does not support 3D,
you will be notified.

3 Optionally, change some options below Common Settings.

4 On the All Effects tab, select the effects you want to activate. Click the
information icon for a short explanation of the respective effect. If an effect is
activated, the wrench icon on the right gives access to further configuration
options like assigning keyboard shortcuts to the effect.

5 Use Apply to enable the effects permanently.

6 Using Virtual Desktops

The desktop environment allows you to organize your programs and tasks on several
virtual desktops. If you often run a lot of programs simultaneously, this minimizes
the number of windows to arrange on your screen. You might, for example, use one
desktop for e-mailing and calendaring and another for word processing and graphics
applications.

Procedure 7 Moving an Application to Another Virtual Desktop

You can display a running application on one or all virtual desktops, or move it to
other desktops.

1 Open the application.

2 Right-click the title bar of the application.

3 Click To Desktop.

4 Select the desktop on which to place the application.

5 To switch to a certain desktop, click the desired desktop in the pager in the
panel. Switch to the next or previous desktop by placing the mouse cursor on
an empty patch on the desktop and move the mouse wheel.

Procedure 8 Configuring Virtual Desktops

You can increase the number of virtual desktops, change the default names, assign
activities, configure effect animations or assign keyboard shortcuts for switching
virtual desktops.

1 To add additional desktops, right-click the pager in the panel and select Add
Virtual Desktop. A new desktop is shown in the pager.

2 For any configuration options, right-click the pager and select Pager Settings.
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3 Use the options on the General screen to configure the appearance of the pager
in the panel.

4 Desktop names, keyboard shortcuts for switching desktops and the switching
type can be configured on the Virtual Desktops screen.

5 Set the options according to your wishes and click OK to apply the changes and
to close the configuration dialog.

7 Using the File Manager

With KDE 4, Dolphin has replaced Konqueror as the default file manager. Konqueror
remains a Web browser (refer to Section 8, “Browsing the Internet” (page 24)). Start
Dolphin, from the Main Menu by selecting Favorites > File Manager or press [Alt] +
[F2] and enter dolphin.

7.1 Dolphin Main Window

The Dolphin main window consists of the following elements:
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Menu Bar:  The menu bar holds menu items for actions like copying, moving, or
deleting files, changing views, starting additional tools, defining your settings, and
getting help.

Toolbar:  The toolbar provides quick access to frequently used functions that can
also be accessed via the menu. If you hover the mouse pointer over an icon, a short
description is displayed.

Location Bar:  The location bar displays the path to the current directory. It is available
in two versions: one shows the path to the current directory with icons for every parent
folder in a “bread crumb” view. Click any icon in the bread crumb view to change to
that directory. The second version of the location bar shows the path to the current
directory as a string of text you can edit.

Panels:  By default, Dolphin shows the Places panel. It allows quick access to some
often-used places like your home directory, the root directory of the file system (/ ),
the trash bin, and removable media. There are several other panels you can add to
the main window by clicking View > Panels.

Display Field (Working Space):  The display field shows the contents of the selected
directory or file. By default, Dolphin displays the contents of your home directory on
start-up. By default, clicking a folder or file in Dolphin directly starts an action: Dolphin
loads the file into an application for further processing or opens the folder.

Status Bar:  Shows the file type and size of the currently selected object and allows
you to enlarge or diminish the size of the icons or entries shown in the display field.

7.2 Managing Files and Folders with Dolphin

To perform actions like copying, moving, creating or deleting files, you need appropriate
permissions to the folders and files involved in your action.

To copy, move, or delete a file or folder, proceed as follows:
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1 In order to select one or multiple files and folders in Dolphin, move your mouse
pointer over the file or folder but do not click. A green cross appears on the
upper-left edge. If you click it, the object is selected. To deselect again, click the
red minus icon that appears if the object is currently selected.

Alternatively, press [Ctrl] and click the objects you want to select or deselect.

2 Right-click and select Copy or Cut  from the context menu.

3 Navigate to the destination folder in which to insert the object.

4 To create a new folder at the current location, select File > Create New > Folder
or press [F10]. Enter a folder name in the new window and press [Enter].

5 To insert the object you copied or cut in Step 2 (page 22), right-click the
destination folder in the main display field and select Paste. The object is copied
or moved there.

6 To delete a file or folder, right-click the object in the main display field and select
Move to Trash from the context menu. The object is moved to the trash bin.
From there, you can restore it if necessary or delete the object permanently.

To quickly filter for certain filenames in the current directory, press [Ctrl] + [I] to add
the Filter input field to the bottom of the Dolphin main window. Type any part of the
filename you are searching for to see all files in the current directory containing the
search string. For more detailed and advanced searches, press [Ctrl] + [F] to use the
desktop search. For more information, refer to Section 14.2, “Using Strigi Desktop
Search” (page 33).

7.3 Configuring Dolphin

Dolphin offers many options for adjusting the view and the overall settings according
to your preferences.

Procedure 9 Changing the View

1 To switch from the bread crumb view to the editable version of the location bar,
press [F6]. Enter a path to a directory by typing it in. After typing an address,
press [Enter] or click on the background of the bread crumb view.

To delete the contents of the location bar click the black X symbol on the left.
To switch back to bread crumb view, press [Ctrl] + [L].

2 To change the view of the currently displayed folder, either click Icons, Details,
or Columns in the toolbar. Dolphin remembers the selected view for each folder.
Click Split or press [F3] to view the contents of the current folder in two separate
columns. Now you can navigate to a different directory in each column and
easily drag or drop objects or compare the contents of directories. Press [F3]
again to leave the split view.
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3 To make Dolphin also show hidden files, select View > Show Hidden Files.

4 To view more details about the files (like access permissions or ownership)
in the working space, select View > Additional Information and enable the
corresponding options.

5 To add further directories to the Places panel, drag a folder from the working
space to the Places panel and drop it there. Right-click and use the context
menu to hide, edit or remove entries from Places.

6 To add more panels to the main window, select View > Panels and select
additional panels such as Folders, or Terminal.

Detach the panels from the main Dolphin window by clicking the left icon at the top
of each panel. Click the panel's title bar and drag it to another place on the desktop.
To reintegrate the panel into the Dolphin window, click the left symbol at the top of the
panel again.

Procedure 10 Changing Dolphin's Overall Behavior

If you want to change Dolphin's overall behavior or view, select Settings > Configure
Dolphin and explore the options offered in the Dolphin configuration dialog.

1 To use the same view mode for all folders, click General in the left sidebar and
activate Use Common View Properties for All Folders. Click View Modes in the
left sidebar and adjust the options for the individual view modes. Click Apply
to save the changes.

2 If you want Dolphin to show a different directory on start-up, or if you want to
permanently use the editable location bar instead of the bread crumb view, click
Startup in the left sidebar and change the relevant options.
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3 To configure which entries and services to show in the Dolphin context menu,
click General. On the Context Menu tab, activate the entries to show. Click
Services in the left sidebar and activate or deactivate the respective services
to appear in the context menu.

4 Click OK to save the changes and to close the Dolphin configuration dialog.

8 Browsing the Internet

Apart from Konqueror (KDE's default Web browser), also includes the default Firefox
Web browser. To start Konqueror or Firefox, press [Alt] + [F2] and enter konqueror
or firefox.

With features like tabbed browsing, pop-up window blocking, and download and image
management, both browsers combine the latest Web technologies. Their easy access
to different search engines helps you find the information you need.

Enter a URL in the location bar to start browsing. To open a new, empty tab, press [Ctrl]
+ [T]. To open a link in a new tab, click the link with your middle mouse button. Right-
click the tab itself to access more tab options. You can create a new tab, reload one
or all existing tabs, or close them. You can also change the sequence of the tabs by
dragging and dropping them to the desired position.

8.1 Finding Information

Both browsers offer different kinds of search options: you can find information on the
Web or you can search the current Web page for keywords.
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Procedure 11 Searching the Web

1 To start a search on the Web, click the left icon in the search bar (located next
to the location bar) to open a list of search engines.

2 Select the desired engine and type your search keywords into the input field.

3 Press [Enter] to start the search.

4 To search the current Web page with Firefox or Konqueror, press [Ctrl] + [F]
to open a find bar at the bottom of the window. Enter your search keyword
there and use the buttons beneath the bar to search in different directions or to
configure search options such as Match Case.

Konqueror offers predefined Web shortcuts for quickly searching the Web. For
example, to search the Web for yast using the Google search engine, just type gg:
yast into the Konqueror location bar (or the Run Command dialog) and press [Enter].

You can also define individual Web shortcuts in Konqueror and Firefox as described
in Section 8.3, “Configuring Preferences” (page 25).

8.2 Downloading Files from the Web

If you download a file with Firefox or Konqueror, a dialog window appears asking you
if you want to save the file or to open it with a specific application. Also choose if to
remember the action you selected for this type of file. By default, Firefox saves the file
to the folder configured in the Firefox Preferences and shows your finished downloads
in the Downloads dialog.

To open the downloaded files directly from there, right-click and select Open. To clean
up the history of downloaded files, click Clear List.

8.3 Configuring Preferences

Adjust preferences in Konqueror or Firefox. In Konqueror, access the configuration
dialog with Settings > Configure Konqueror. To change the behavior of Konqueror as
Web browser, select one of the Web Browsing sub categories in the left sidebar to
show the options for the relevant category. For example, you can “hide” Konqueror's
real identity and make Konqueror identify as a different browser (for example, Internet
Explorer*) for certain Web sites you visit. To do so, select Browser Identification, and
click New to add a new, site-specific identification.
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You might also want to configure the Web shortcuts you can use with Konqueror (and
the Run Command dialog). In the Konqueror configuration dialog, click Web Shortcuts
to see which shortcuts are already defined. Click New to define new shortcuts. Leave
the Konqueror configuration dialog with OK to apply your changes.

In Firefox, select Edit > Preferences to open the Firefox Preferences. Click the icons
in the upper display field to access the options for the relevant category. For example,
change the default download folder on the General page, or adjust the pop-up blocking
feature on the Content page. Click OK to apply the changes.

To configure a Web shortcut for a search in Firefox, browse to the Web page with the
desired search field. Right-click the search field and choose Add a Keyword for this
Search.... Enter a Keyword and leave the dialog with OK.

9 Managing Passwords

When you enter a password in a KDE application for the first time (in KMail or
Konqueror, for example), you are asked if you want to store the password. If you click
Yes, KWallet wizard starts by default. KWallet is a password management tool that can
collect all passwords and store them in one or more encrypted files (called wallets).
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To activate KWallet, select Basic Setup and click Next. Select Yes, I wish to use the
KDE wallet to store my personal information and enter a password. This is your master
password for the default wallet (named kdewallet) that is created during the next
step.

WARNING: Protect Your KWallet Password

If you forget your master password for any wallet, it cannot be recovered.
Furthermore, anyone who knows your master password can obtain all information
contained in the respective wallet.

Click Finish to close the wizard. If you started the KWallet wizard initially from another
application like Konqueror or KMail, KWallet will prompt you to enter the password once
again in order to store the password for this application in the newly created wallet.
After initial configuration you can open your wallet at any time to view, search, delete, or
create entries. Normally you do not need to insert an entry manually. KDE recognizes if
a resource requires authentication and KWallet starts automatically, prompting you for
the KWallet password. However, you can add additional data if you wish. To configure
any KWallet options, press [Alt] + [F2] and enter kwalletmanager. In the KDE Wallet
Manager that opens select Settings > Configure Wallet.

Whereas KWallet is designed to centrally manage passwords for several KDE
applications, Firefox also offers the ability to store data when you enter a username
and a password on a Web site. If you accept by clicking Remember, the password will
be stored on your hard disk in an encrypted format. The next time you access this site,
Firefox will automatically populate the login fields.

Firefox does not use KWallet to store passwords, but rather uses it's own password
store. To review or manage your passwords in Firefox, click Edit > Preferences >
Security > Saved Passwords....
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10 E-Mailing and Calendaring

For reading and managing your mails and appointments, you can use Kontact as your
personal information management tool (PIM). Kontact combines KDE applications like
KMail, KOrganizer, and KAddressBook into a single interface. This gives you easy
access to your e-mails, calendar, address book, and other PIM functionality. Kontact
can also manage multiple e-mail accounts.

10.1 Starting Kontact for the First Time

To start Kontact, press [Alt] + [F2] and enter kontact. To access one of its components
like KMail, click the corresponding icon in the left sidebar.

Before you can send or receive mails, you must configure an e-mail identity and
account:

1 From the menu, select Settings > Configure Kontact....

2 In the left side pane under Mail, click Identities and select the identity that KMail
has automatically created for you. Modify it by entering your full name and e-
mail address and confirming your changes.

3 Click Accounts in the left side pane under Mail and Add at least one account
on the tabs for Receiving and Sending mails. (Optionally, you can configure
multiple mail accounts).

Usually, the following information is required for both incoming and outgoing
mail: Account Type, Server Name and Port. Depending on the account, you
may also need to set encryption or authentication options. If you are not sure
about the settings or items to select, consult your Internet Service Provider or
system administrator.
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4 Confirm the setup and leave the configuration dialog with OK.

To write a new mail, click the Mail icon in the Kontact main window and press [Ctrl] +
[N] to open the mail composer. After you have finished your mail, click Send to send
it immediately. In case you have configured multiple e-mail accounts, keep the Send
button pressed, then select the account from which you want to send the mail.

11 Instant Messaging with Kopete

Kopete is an online messenger application that allows multiple partners connected
to the Internet to chat with each other. Kopete currently supports a number of
common messenger protocols, such as AOL* Instant Messenger (AIM), Gadu-Gadu,
GroupWise® Messenger, ICQ, Jabber*, SMS, and Yahoo!*. To be able to use instant
messaging (IM), you must register with a provider offering IM services and configure
a Kopete account.

To start Kopete, press [Alt] + [F2] and enter kopete. If started for the first time, click the
wrench icon at the bottom of the Kopete window to create an account. Kopete guides
you through the setup steps like selecting the messaging service, and entering the
respective account information like user name or ID, server name and port and any
authentication details like passwords. If you have not registered with the provider for the
selected messaging service yet, click Register New Account. In the browser window
that opens, enter your user data to register. Switch back to Kopete and enter the data
received on registration. Complete the configuration of your account by clicking Finish.

If you decided to go online after configuring your account, you can now add contacts in
the main Kopete window. If the Kopete window shows offline , first click File > Set
Status > Online and enter your password if you are prompted for it. After connecting,
click File > Add Contact and select the Kopete account for which you want to add
contacts. Enter the contact data or search for a contact and click OK.

To view all your contacts, even if they are offline at the moment, select Settings > Show
Offline Users.

To start a chat with someone, click the desired contact and type your message in the
lower part of the chat window. Press [Enter] to send the message. The upper part of
the window displays the messages you have sent and received.



30 Start-Up

12 Starting LibreOffice
The office suite LibreOffice offers a complete set of office tools, including word
processor, spreadsheet, presentation, vector drawing, and database components.
Because LibreOffice is available for a number of operating systems, you can use the
same data across different computing platforms.

To start LibreOffice press [Alt] + [F2] and enter ooffice. In the window that appears,
select the LibreOffice module you want to open. To create a new document, select File
> New and choose the type of document to create. To open an existing document,
select Open and choose the appropriate file from the file system.

13 Viewing PDF Files and Other Documents
Documents that need to be shared or printed across multiple platforms can be saved
as PDF (Portable Document Format) files, for example, in the LibreOffice suite. View
them with Okular, the default KDE document viewer.

13.1 Using Okular Document Viewer

Apart from PDF files, Okular allows you to view a great number of file formats, such as
PostScript, several image formats, OpenDocument format (ODF), OpenDocument text
(ODT), some eBook formats (ePub), and even Microsoft* Compiled HTML Help (CHM).
Okular also provides support for bookmarks, annotations, form fields and multimedia
content, and the rotation of pages.

Start Okular from the Main Menu or press [Alt] + [F2] and enter okular.

To open a document, select File > Open and choose the desired file from the file
system. Navigate through the document by using the navigation icons at the top or
bottom of the window. Depending on which icon you click on the navigation panel on
the left, the sidebar either shows a table of Contents, a Thumbnail view of each page,
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the Reviews, or your Bookmarks for this file. To filter for any text listed in the sidebar or
the overall document, enter a string into the input field at the top of the sidebar. If you
want to select and copy text or images from the file in Okular, click the Selection icon
in the toolbar and select one of the options from the context menu. Click the Browse
icon to switch back to browsing the document.

Procedure 12 Working with Bookmarks and Annotations

With Okular, you can review a document by highlighting certain text parts or adding
annotations or bookmarks that Okular then attaches to the file in the form of metadata.
Note that the annotations and markers you add are not stored within the document,
so you cannot print them or pass them on to other users.

1 To add a bookmark for a page, click the page in the sidebar or in the main
display field and press [Ctrl] + [B]. The page is added to the Bookmarks list on
the left sidebar. Right-click the bookmark entry to access a context menu for
going to this bookmark or renaming, or removing it.

2 To create an annotation for a page, press [F6] and select one of the annotation
tools from the toolbar that appears. The annotation is added to the list of
Reviews and is flagged with the login name of the user who created it. Use the
icons at the bottom of the sidebar to group the annotations by page, by author
or to show the annotations for the current page only.

3 To open a pop-up note and add text for an annotation (or to remove an
annotation), right-click the annotation entry in the Reviews list and select
the corresponding menu item. The annotations or markers you added are
automatically attached to the file, you do not need to save them.

13.2 Using Acrobat Reader

If Acrobat Reader is not installed by default, install the acroread package with YaST.
To start Acrobat reader, press [Alt] + [F2] and enter acroread.. Click File > Open,
locate the desired PDF file and click Open to view the file.
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14 Searching for Data

KDE provides more than one application for finding data on your computer or in the
file system. One application is KFind, which is described below.

14.1 Using KFind

To perform basic and advanced searches, use KFind. Start it from the Main Menu by
clicking Applications > Find Files/Folders or press [Alt] + [F2] and enter kfind.

Procedure 13 Searching by Name

To use a filename (or a part of it) as the search keyword, proceed as follows:

1 Enter the filename or a part of the filename in the Named input field. Use wild
cards, such as an asterisk (*), to indicate missing characters in the filename.

2 Specify the folder in which to search for the file. Either enter a path to the folder
in Look in or click Browse to locate the folder.

3 To search subfolders, check Include Subfolders.

4 Click Find to start the search. The results are displayed in the lower part of the
dialog. To directly open the result, just click it. Right-click it to choose one of the
options from the context menu.

Procedure 14 Searching by Contents or Properties

For a more detailed search, you can also specify further options, such as a text the
file must contain or the creation or modification date of a file. To search for content
or properties, proceed as follows:

1 On the Name/Location tab, specify at least the path to search for the file. You
can leave Named empty.

2 To search for certain content in a file, click the Contents tab. In Containing Text,
enter the word or phrase the file to find must contain. This option does not work
for all types of files.

3 To search for properties such as creation or modification date of the file, click
the Properties tab and choose the options you want.
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4 Click Find to start the search.

14.2 Using Strigi Desktop Search

Strigi Desktop Search offers advanced search capabilities,by additionally searching for
metadata such as tags, ratings, and even source URLs for downloads. It requires the
services nepomuk and strigi to run. To activate these services, press [Alt] + [F2] and
enter strigi. Choose Nepomuk/Strigi server Configuration to start the configuration
dialog. Enable the two services on the tab Basic Settingsand leave the dialog by
clicking Apply and OK.

Once activated, you can use KRunner ([Alt] + [F2]) to search for files by just typing a
keyword. A more advanced search interface is available in the Dolphin file manager.
Press [Ctrl] + [F] in Dolphin to activate the desktop search. You can filter the search
results for Filename, Content or location.

15 Creating a CD or DVD

If you possess a CD or DVD writer, you can burn files to a CD or DVD with K3b. To
create a data CD or DVD, proceed as follows:

1 Press [Alt] + [F2] and enter k3b. K3b opens.

2 Select File > New Project > New Data Project from the main menu.

3 Use the tree view in the top left part of the window to search for the files or
folders to burn. When they appear in the top right part of the window, drag and
drop them into the Current Projects window.
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4 Insert a writable CD or DVD into the device then click the Burn icon.

5 Check the settings on the Writing tab. Usually the defaults should work well
for almost all files. If you wish, you can change more options (for example the
Volume Name) on the Filesystem tab.

6 Click Burn.

16 Managing Your Digital Image Collection

With digiKam it is easy to manage your digital images: download your images from
the camera, edit and improve them, organize them in albums (or flag them with tags
for easy retrieval, independent of folders or albums), archive them on CD or DVD, or
export them to a Web image gallery.

digiKam also contains a set of useful batch functions and plug-ins, allowing you
to convert multiple images to various different formats, rename multiple images, or
automatically improve them with functions such as red eye reduction, speck removal,
and hot pixel removal. Various filter and effects plug-ins help create works of art from
your digital images.

To start digiKam, press [Alt] + [F2] and enter digikam. On initial start-up, the first-run
wizard appears to guide you through the setup.
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digiKam's main window contains a tree view on the left and shows thumbnails of the
images on the right. For quick access to your images, use the sidebar on the left,
which allows you to switch between different views, for example, sorting the images
according to Albums, Dates, Tags or Searches. To enter digiKam's viewing and editing
mode, double-click an image thumbnail.

17 Managing Your Music Collection
KDE's Amarok music player allows you to play various audio formats, create playlists,
listen to streaming audio broadcasts of radio stations on the Internet and subscribe to
podcasts. The file types supported depend on the engine used for Amarok.

To start Amarok, press [Alt] + [F2] and enter amarok. On first start, Amarok asks for
the folders where to look for your music files.
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Amarok's main window shows a sidebar on the left providing different views: your
local music collection, some addresses to listen to podcasts or streams from the
Internet, your playlists and a file browser. The middle part, the context browser, displays
information about the current track, the Wikipedia page of the artist and the song's
lyrics by default. The right part of the window shows the current playlist. To play music,
just drag and drop items from any of the sidebar browsers to the playlist area. Double-
click an item in the playlist to start playback.

If your music files are properly tagged (containing at least information about the artist
and album), you can make use of several nice Amarok features. To automatically
retrieve the album cover images from Amazon, select Tools > Cover Manager and click
Fetch Missing Covers. The next time you play a track from this album, the cover is
displayed in the context browser and on the on-screen display. To learn more about
the artist, click on the Wikipedia button in the middle area to make Amarok search for
the appropriate Wikipedia article.

To configure the use of another engine (or various other Amarok features), select
Settings > Configure Amarok.

18 Logging Out
Log out (and leave the system running), restart or shut down the computer.

18.1 Logging Out or Switching Users

Click the Main Menu button on your panel and select Leave > Logout. This ends your
session but leaves the system running. To start a parallel session as a different user,
select Leave > Switch User instead.

18.2 Restarting or Shutting Down the Computer

Click Leave, then select one of the following options:

Sleep
Only available if your computer provides power management functionality. Pauses
your computer without logging you out. All your data and the session data is saved
to RAM.

Hibernate
Only available if your computer provides power management functionality. Pauses
your computer without logging you out. All your data and the session data is saved
to disk before the system is laid to rest. It is thus protected against data loss should
you lose power in the meantime.

Restart
Restarts your computer.

Shutdown
Logs you out of the current session, then turns off the computer.



KDE Quick Start  37

19 For More Information
To learn more about KDE and KDE applications, also refer to http://www.kde
.org/  and http://www.kde-apps.org/ .

http://www.kde.org/
http://www.kde.org/
http://www.kde-apps.org/
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provides the tools that Linux* users require in their daily activities. It comes with an
easy-to-use graphical environment, the GNOME* desktop, that communicates with the
underlying Linux system, to let you access and manage files, folders, and programs.
provides an integrated suite of applications for a wide range of office, multimedia, and
Internet activities. The LibreOffice suite, which allows you to edit and save files in a
number of formats, is also included. The office suite is available for several operating
systems. Therefore, you can use the same data across different computing platforms.

1 Getting Started

When you start your system, you are usually prompted to enter your username and
password. If someone else installed your system, check with your system administrator
for your username and password.

After logging in to GNOME for the first time, you see the GNOME desktop, offering the
following basic elements:
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Desktop Icons:  Access programs and features on your system by double-clicking an
icon. Right-click an icon to get additional menus and options. By default, the desktop
features several key icons, including your personal Home folder and a trash can for
deleted items. Other icons representing devices on your computer, such as CD drives
or USB flash disks, may also be present on the desktop, and you can add as many
icons on your desktop as you like. If you double-click your Home folder, the Nautilus
file manager starts and displays the contents of your home directory.

Bottom Panel:  The desktop includes a panel at the bottom of the screen. This panel
contains the Computer menu, the Tomboy Notes applet, a taskbar to display buttons for
all currently running applications, and the system tray. You can also add applications
and applets to the panel for easy access.

Main Menu:  Click Computer on the left side of the bottom panel to open the main
menu. Commonly used applications appear in the main menu along with recently used
applications. Click the Documents button to display your recent documents, or click
the Places button to display your favorite places (such as your home directory, your
desktop, or available network servers). Click More Applications to access additional
applications, listed in categories. Use the options on the right to access help, open the
GNOME Control Center, run YaST, install additional software, lock your screen, log
out of the desktop, shut down the system, or check the status of your hard drive and
network connections.

System Tray:  The right side of the bottom panel shows some smaller icons, including
the system clock that displays the current date and time, the Workspace Switcher, the
volume control, and icons for several other helper applications.

Taskbar:  By default, all applications running on the current desktop are displayed in
the taskbar (the area in the middle of the panel between the Computer button and the
system tray). You can access these applications by clicking their names in the taskbar.
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Right-click the application's name to see options for moving, restoring, or minimizing
the window.

Desktop Menu:  Right-click an empty spot on the desktop to display a menu with
various options. Click Create Folder to create a new folder on the desktop. Use
Create Launcher to create a launcher icon for an application. Provide the name of the
application and the command for starting it, then select an icon to represent it. You
can also change the desktop background, open a terminal, create a document, and
align desktop icons.

1.1 Modifying Desktop Panels

The bottom panel can be customized to meet your individual needs, and additional
panels can be added and configured to further personalize your desktop.

To add a new panel, right-click a blank space in the bottom panel and select New Panel.
To delete a panel, right-click a blank space in the panel and select Delete This Panel.
requires that at least one panel is left on the desktop.

1.2 Adding and Removing Panel Icons

1 Right-click a blank space on the panel and select Add to Panel.

2 Browse to the desired program and double-click it to add it to the panel.

3 To remove a program icon from a panel, right-click its icon in the panel and
select Remove From Panel.

2 Starting Programs

Start programs from the Main Menu or from the command line, using a shell or the Run
Command. Additionally, you can start programs from the desktop or the panel by left-
clicking the program icon once.

2.1 Using the Main Menu

To run a program in , click Computer on the panel to open the main menu screen. If the
program you want does not appear in the main menu screen, click More Applications
to view a list of all available applications grouped in categories. You can also limit the
list to show only applications with a specific name by entering all or part of the name
into the Filter field. Click an entry in the list to start the corresponding program.
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You can also add an icon to your panel that opens a more traditional version of the
main menu. Right-click a blank space on the panel, select Add to Panel, then double-
click Traditional Main Menu.

If you already know the name of an application but are not sure how to start it from the
main menu, use the Search field in the main menu. Click Computer, type a portion of
the application name in the Search field, then press [Enter]. If the application is installed
on your system, the name of the application appears in the Needle  search dialog box.
Click the name to start the program.

2.2 Using the Run Application Dialog

Press [Alt] + [F2] to open the Run Application dialog. Type a command, for example,
f-spot, and press [Enter] or click Run to start the application. The command to start
the application is often (but not always) the application name written in lowercase.
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3 Handling Media
If you insert a CD or DVD into your drive or plug in a pluggable device (for example,
a USB stick or removable hard disk), GNOME opens Nautilus and shows the content
of the media.

4 Customizing Your Desktop
Easily add, delete, and create shortcut icons on your desktop. You can also change
icon properties and the desktop background to suit your needs.

4.1 Adding Program Icons to Your Desktop

1 Click Computer.

2 Browse to the desired program.

3 Click and drag the icon to the desktop and position it as desired.

To delete an icon from your desktop, simply click the program icon and press the
[Delete] key on your keyboard.

4.2 Changing the Desktop Background

1 Right-click the background.

2 Select Change Desktop Background.

3 To select a wallpaper from the pre-installed images, browse to and select the
desired image. After you select it, the background changes automatically.

4 To add an image, select Add, browse to the desired image, then click Open.
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5 To display a colored background, select the solid color rectangle from the top
of the list; then, from Colors, select the fill pattern and the desired colors.

6 Click Close.

4.3 Using the GNOME Control Center

In addition to letting you change individual desktop elements, GNOME lets you
extensively personalize your desktop. You can find more settings to adjust the overall
appearance and behavior of your desktop in the GNOME Control Center. There, you
can also change fonts, keyboard and mouse configurations, regional and language
settings, parameters for your Internet and network usage, and more.

To start the Control Center, click Computer, then click Control Center on the right of
the main menu.

5 Applying Desktop Effects

If your computer supports a 3D graphics card with Xgl, you can use graphical effects
like turning your desktop into a rotating 3D cube, enabling translucent or transparent
windows, and zooming in and out of the desktop screen. You can also use other window
effects such as shadows, fading, and transformations. If you do not have a 3D graphics
card, some effects may be disabled or reduce the performance of your system. If the
performance of your system is too low, disable the compositing effect for your current
session with [Alt] + [Shift] + [F12].
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To configure the effects on your desktop, proceed as follows:

1 Start the personal settings window as described in Section 4.3, “Using the
GNOME Control Center” (page 44).

2 Select Look and Feel > Desktop Effects and choose Enable Desktop Effects. If
your graphic card does not support 3D, you will be notified.

3 Select the effects in one of the tabs.

6 Using Virtual Desktops
The desktop environment allows you to organize your programs and tasks on several
virtual desktops. If you often run a lot of programs simultaneously, this minimizes
the number of windows to arrange on your screen. You might, for example, use one
desktop for e-mailing and calendaring and another for word processing and graphics
applications.

Procedure 15 Moving an Application to Another Virtual Desktop

You can display a running application on one or all virtual desktops, or move it to
other desktops.

1 Open the application.

2 Right-click the title bar of the application.

3 Click Move to Another Workspace.

4 Select the desktop on which to place the application.
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5 To switch between desktops, click the desired desktop in the pager in the panel.

Procedure 16 Adding Additional Virtual Desktops

Some users might need more desktops than are provided by default. To add
additional desktops, do the following:

1 Right-click the pager in the panel and select Preferences. A configuration dialog
appears:

2 Decrease or increase the Number of Workspaces.

3 If you want to change the names of the desktops double click on the list entries
and enter the new names.

7 Managing Files and Folders

Use the Nautilus File Manager to create and view folders and documents, run scripts,
and create CDs of your data. To open Nautilus, double-click your home directory icon
on the desktop. You see the contents of your home directory.
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The elements of the Nautilus window include the following:

Menu  Lets you perform most tasks.

Toolbar  Lets you quickly navigate among files and folders, and provides access to
files and folders.

Location Bar  Lets you locate files, folders, and URI sites. If you prefer text based
location display to the button based one, select Go > Location.

Side Pane  Lets you navigate or display information about the selected file or folder.
Use the drop-down list to customize what is shown in the pane. The list includes ways
to view information about files, perform actions on files, attach emblems to files, view
a history of recently visited sites, and display your files in the tree system.

View Pane  Displays folders and files. Use the options on the View menu to increase or
decrease the size of content in the view pane and to display items as a list or as icons.

Status Bar  Displays the number of items in a folder and gives the available free space.
When a file is selected, the status bar displays the filename and size.

7.1 Archiving Folders

If you have files you have not used recently but want to keep on your computer, you
can compress the files into a tape archive (TAR) format.

1 In the Nautilus view pane, right-click the folder you want to archive and select
Compress.
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2 Accept the default archive filename or provide a new name.

3 Select a file extension from the drop-down list. Use tar.gz  for the most
common archive form. Use zip if you need to protect the archive with a
password.

4 Specify a location for the archive file, then click Create.

To extract an archived file, right-click the file and select Extract Here.

7.2 Using Bookmarks

Use the Nautilus bookmarks feature to mark your favorite folders.

1 Open the folder you want to create a bookmark for.

2 Click Bookmarks > Add Bookmark. The bookmark is added to the list, with the
folder name as the bookmark name.

3 To select an item from your bookmarks list, click Bookmarks, then click the
desired bookmark in the list.

You can also organize your bookmarks list by clicking Bookmarks > Edit Bookmarks
and making your selections in the dialog box.

To change the order of your bookmarks, click a bookmark shown in the Edit Bookmarks
dialog and drag it to the desired location.
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8 Browsing the Internet with Firefox
Firefox* is one of the most popular Web browsers. It has all the familiarity of other
browsers, plus added features such as security and privacy tools.

To start Firefox, click Computer > Firefox Web Browser.

With features like tabbed browsing, pop-up window blocking, and download and
image management, Firefox combines the latest Web technologies. Its easy access to
different search engines helps you find the information you need. Enter a URL in the
location bar to start browsing.

To open a new empty tab in Firefox, press [Ctrl] + [T] or the “+” button next to the last
tab . Type a new URL to browse. To open a link in a new tab, click the link with your
middle mouse button. Right-click a tab to access more tab options. You can create a
new tab, reload one or all existing tabs, or close a single tab or all tabs. You can also
change the sequence of the tabs by dragging and dropping them to a new position.

8.1 Finding Information

1 To start a search on the Web type your search keywords in the integrated search
box on the right of the location bar, then press [Enter]. The results are displayed
in the active window or tab.

2 To use a different search engine than the default, click the icon in the search
box to open a list of other search engines.

3 Click the desired engine, then press [Enter] to start the search.

To search the current Web page for words, press [Ctrl] + [F] to open the Find bar at
the bottom of the window. Enter your search keyword there and use the buttons to the
right of the box to search in different directions or to select all hits in the text.
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8.2 Downloading Files from the Web

If you download a file with Firefox, the Firefox download manager starts and saves this
file to the folder configured in Firefox Preferences. By default, the Downloads folder in
your home directory is the destination for downloaded files. Firefox shows your finished
downloads in the Downloads window.

Open the downloaded files directly from the Downloads window or from the destination
folder. To clean up the history of downloaded files, click Clean List.

8.3 Configuring Preferences

To adjust the default download folder or to activate or modify the pop-up blocking
feature, click Edit > Preferences.

Here also configure many other settings such as appearance, language, privacy, and
tab options. Click the icons and set the options on each page according to your
preferences. Click Close to apply the changes.

9 Managing Passwords
GNOME allows you to store your passwords and encryption keys in a keyring. This is
useful if you want to store passwords for different web sites.
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To create a new keyring, proceed as follows:

1 Press [Alt] + [F2] and enter seahorse.

2 Select File > New.

3 Choose Password Keyring and proceed with Continue.

4 Enter a name for your keyring. Then, a dialog box opens.

5 Enter your password, confirm the password, and click OK.

You can create as many keyrings as you like. For example, you can create one for
private and one for business. To store passwords in your keyring, proceed as follows:

1 Press [Alt] + [F2] and enter seahorse.

2 Select File > New.

3 Choose Stored Password and proceed with Continue.

4 Select your keyring, enter description and password.

5 Finish with Add.

10 E-Mailing and Calendaring
For reading and managing your mail and events, offers you Evolution™, a groupware
program that makes it easy to store, organize, and retrieve your personal information.

Evolution seamlessly combines an e-mail, a calendar, an address book, and a task
list in one easy-to-use application. With its extensive support for communications and
data interchange standards, Evolution can work with existing corporate networks and
applications, including Microsoft* Exchange.
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To start Evolution, click Computer > Evolution Mail and Calendar.

The first time you start it, Evolution prompts you with a few questions as it sets up a
mail account and helps you import mail from your old mail client. It shows you how
many new messages you have and lists upcoming appointments and tasks, as well as
the current weather and news from news feeds. The calendar, address book, and mail
tools are available in the shortcut bar on the left.

Press [Ctrl] + [N] to open a new item for whatever part of Evolution you are working in.
In mail, this creates a new message. If you are in the address book, [Ctrl] + [N] creates
a new contact card, and in the calendar, it creates a new appointment.

For more information on using Evolution, click Help > Contents in any Evolution
window.

11 Instant Messaging with Empathy

Empathy is a multiprotocol instant messaging (IM) client. It is compatible with AOL*
Instant Messenger (AIM), Google Talk, GroupWise® Messenger, ICQ, IRC, MSN
Messenger, Jabber/XMPP, Yahoo!*, and other networks.

With Empathy, you can log in to multiple accounts on multiple IM networks
simultaneously. Empathy also supports many features of the various networks, such
as video chat, file transfer, away messages, and typing notification.

To start Empathy, click Computer > More Applications > Internet > Empathy, or press
[Alt] + [F2] and enter empathy.

To add an account to Empathy, either use the initial configuration wizard, or select Edit
> Accounts. Click Add and select the protocol you want to use, and type your login
information in the appropriate fields. Click Log in to activate you IM account. Finally
click Close to start chatting with your friends.

Add contacts by clicking Chat > Add Contanct. Select account, identifier and alias
information relevant for the new contact and confirm with Add. However, you must be
online and connected to the selected messaging service to add a contact to your list.

To start a chat, double-click the desired contact and type your message in the lower
part of the chatting window. Press [Enter] to send the message. The upper part of the
window displays the messages you have sent and received.

12 Starting LibreOffice

The LibreOffice office suite offers a complete set of office tools, including word
processing, spreadsheet, presentation, vector drawing, and database components.
Because LibreOffice is available for a number of operating systems, you can use the
same data across multiple platforms.
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To start LibreOffice, click Computer > LibreOffice Writer. To create a new document,
click File > New, then choose the type of document you want to create. To open an
existing document, click Open, then select the file you want from the file system.

13 Viewing PDF Files and Other Documents

Documents that need to be shared or printed across platforms are often distributed as
PDF (Portable Document Format) files. PDF files can be created using the LibreOffice
suite or other applications. The GNOME PDF viewer is called Evince. It can be used
to view PDFs and many other document formats, like PostScript, DjVu, DVI, and multi-
page TIFFs.

To start Evince, press [Alt] + [F2] and enter evince .

1 To view a PDF file, double-click the PDF file.

2 Use the navigation icons at the top of the window to navigate through the
document. If the PDF document provides bookmarks, you can access them in
the left panel of the viewer.

14 Searching for Data

GNOME provides more than one application for finding data on your computer or in
the file system.

14.1 Using Desktop Search

To locate files or programs on your computer, click Computer. Enter a search term in
the Search field and press [Enter]. The results are displayed in the Needle.
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You can also start the Needle application by clicking Computer > More Applications >
Accessories > Desktop Search.

14.2 Using GNOME Do

GNOME Do describes itself as an “intelligent launcher that makes performing common
tasks on your computer simple and efficient.” It is extensible with plug-ins.

Start it by pressing [Super] + [Space]. The [Super] is normally located on the left and
right [Windows] or [Penguin] key.

GNOME Do allows you to perform specific actions. For example, if you type b, it
displays a starter button for the Banshee, the music player:

To customize GNOME Do to your needs, select the arrow button on the upper-right
corner of the window and select Preferences. It gives you a list of plug-ins to search
for mails in Evolution, listen to your music, etc.
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15 Creating a CD or DVD

If your system has a CD or DVD writer, use the Nautilus file manager to burn CDs
and DVDs.

1 Click Computer > More Applications > System Tools >  CD/DVD Creator, or just
insert a blank disk.

2 Copy the files and folders you want to put on the CD or DVD into the Nautilus
CD/DVD Creator window.
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3 Click Write to Disk.

4 Modify the relevant information in the Write to Disk dialog box, or accept the
default values, then click Write. The files are burned to the disk. This could take
a few minutes, depending on the amount of data being burned and the speed
of your burner.

You can also use the more advanced burning tool Brasero, or Banshee to burn data
and audio CDs.

16 Managing Your Digital Image Collection

F-Spot is a management tool for your collection of digital images, tailored for the
GNOME desktop. It allows you to assign different tags to your images in order to
categorize them, and offers various image editing options. For example, you can
remove red-eye, crop, and adjust brightness and colors. F-Spot supports all important
image formats, including JPEG, PNG, TIFF, and several vendor specific RAW formats.

You can import photos from your hard drive, your digital camera, or your iPod. You
can also use F-Spot to create photo CDs, generate a Website gallery, or export your
photos to your Flickr, 23, Picasa Web, or SmugMug account.

To access F-Spot, click Computer > F-Spot Photo Browser or press [Alt] + [F2] and
enter f-spot. The first time you run F-Spot, you must define the location from where
you want to import images into your collection. If you already have a collection of
images stored on your hard drive, enter the path to the directory and (optionally) include
subfolders. F-Spot imports these images into its database.
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Thumbnails of your images are displayed in the right part of the window, and detailed
information for a selected image is displayed in a sidebar to the left. By default, your
photos are displayed in reverse-chronological order, so your newest photos are always
at the top. You can sort your photos in chronological order or reverse-alphabetical order
by clicking View > Reverse Order.

A menu bar at the top of the window allows you to access the main menus. A toolbar
below offers several different functions depicted by a matching icon.

17 Managing Your Music and Videos

Use Banshee to import CDs, sync your media collection to a digital media player, play
music directly from a digital media player, create playlists with songs or videos from
your library, create audio and data CDs from subsets of your library, and subscribe to,
download, and listen to your favorite podcasts. Banshee also has an Internet Radio
plug-in that allows you to listen to audio streams.

To open Banshee, click Computer > Banshee Media Player or press [Alt] + [F2] and
enter banshee-1.

When you start Banshee for the first time, you need to import your media to make them
available in the library. To do so, select Media > Import Media from the menu. Choose
an import source and click Import. After successfully importing your media, you can
access them from your library.
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To play a song or a movie, simply select it in the library and click the play button. You
can also use the buttons in the upper left corner to pause a song or play the next or
previous song. Use the loudspeaker button on the right to adjust the volume.

Banshee also has an integrated CD player. When you insert a music CD, your CD title
appears in the left panel. Select the title and click the Play button to play your full CD.

To create audio and MP3 CDs, select the songs you want, then click the Edit > Write
CD from the menu.

18 Logging Out
When you are finished using the computer, you can log out and leave the system
running, or restart or shut down the computer.

18.1 Logging Out or Switching Users

Click Computer > Logout, then select one of the following options:

Log out  Logs you out of the current session and returns you to the login screen.

Switch User  Suspends your session, allowing another user to log in and use the
computer.

18.2 Restarting or Shutting Down the Computer

Click Computer > Shutdown, then select one of the following options:
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Shutdown  Logs you out of the current session, then turns off the computer.

Restart  Logs you out of the current session, then restarts the computer.

Suspend  Puts your computer in a temporary state that conserves power. The state
of your session is preserved, however, including all applications you have running and
all documents you have open.

Hibernate  Suspends your session, using no power until the computer is restarted.
The state of your session is preserved, however, including all applications you have
running and all documents you have open.

19 For More Information
To learn more about GNOME and GNOME applications, refer to http://www
.gnome.org/ .

http://www.gnome.org/
http://www.gnome.org/
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LibreOffice is a powerful open-source office suite that provides tools for all types of
office tasks such as writing texts, working with spreadsheets, creating graphics and
presentations, or designing scientific formulas. With LibreOffice, you can use the same
data across different computing platforms. You can also open and edit files in other
formats, including Microsoft Office, then save them back to this format.

1 Compatibility
LibreOffice can work with documents, spreadsheets, presentations, and databases in
many other formats, including Microsoft Office. They can be seamlessly opened like
other files and saved back to the original format. Though some work has already been
invested in interoperability, occasionally there are still formatting issues. If you have
problems with your documents, consider opening them in the original application and
resaving them in an open format such as RTF for text documents. In case of migration
problems with spreadsheets however, it is advisable to resave them as Excel files and
use this as intermediate format (with CSV format you would lose all cell formatting and
CSV sometimes leads to incorrect cell type detection for spreadsheets).

2 LibreOffice Modules
LibreOffice consists of several application modules (subprograms), which are designed
to interact with each other. All modules feature the same graphical user interface and
similar functionality.

Table 1 The LibreOffice Modules

Module Usage

Writer Text document module

Calc Spreadsheet module
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Module Usage

Impress Presentation module

Base Database module

Draw Vector graphics module

Math Mathematical equation module

3 What is New in LibreOffice

A number of new improvements common to all LibreOffice modules were introduced
since the last release. Here are the most notable ones:

Common Search Toolbar
A unified search toolbar is now present in each LibreOffice module to ease
searching for a text string within open documents. You can toggle the toolbar with
View > Toolbars > Find.

Online Help
If no package with help information (libreoffice-hell-*) is installed,
LibreOffice tries to view the relevant help page online in a Web browser.

New Print Dialog
The Print dialog has been reworked to include useful features, such as simple page
preview and pages per sheet option, in one place.

New Thesaurus Dialog
The new Thesaurus dialog improved in usability so that it is now easier to find
similar or related terms to make the documents language more vivid.

Alpha Channel Import for TIFF Images
LibreOffice modules can now import RGBA TIFF images with their alpha channel
information.
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4 Starting LibreOffice

To start the LibreOffice suite, press [Alt] + [F2], type ooffice and press [Enter]. In
the welcome dialog, select the module you want to open. If an LibreOffice application
is open, you can start any of the other applications by clicking File > New > Name of
Application.

4.1 Saving LibreOffice Files

1 To save a new file, select File > Save or Save as from the Menu Bar or use the
shortcut [Ctrl] + [Shift] + [S].

2 Select the directory where you want to save the file.

3 Enter the filename in the Name box.

4 From the File Type box, select the format in which you want to save the file.

In all modules you can save your documents as native LibreOffice files, LibreOffice
templates, Microsoft files and StarOffice files.

4.2 Navigator and Navigation Shortcuts

The Navigator tool displays information about the contents of a document. It also lets
you quickly jump to different elements. For example, you can use the Navigator to get
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a quick overview of all images included in the document. To open the Navigator, click
View > Navigator or with [F5]. The elements listed in the Navigator vary according to
the LibreOffice module being used.

You can also navigate your files with the following shortcuts:

Table 2 Navigation Shortcuts

Action Shortcut

Delete to the End of the Word [Ctrl] + [Del]

Delete to the Beginning of the Word [Ctrl] + [<—]

End of Document [Ctrl] + [End]

End of Line [End]

Select All [Ctrl] + [A]

Start of Line [Home]

Top of Document [Ctrl] + [Home]

Word Left [Ctrl] + [←]

Word Right [Ctrl] + [→]

4.3 Using and Creating Templates

LibreOffice comes with a set of predefined templates, and you can find additional
templates on the Internet. If you want to create your own templates, you need to
determine what you want the document to look like and create the styles you need in
that template.

For text document, spreadsheets, presentations, and drawings, you can easily create
a template from an existing document as follows:

1 Start LibreOffice and open or create a document that contains the styles that
you want to use as a template.

2 Click File > Templates > Save.

3 Specify a name for the template.

4 In the Categories box, click the category where you want to place the template.
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5 Click OK.

5 LibreOffice Writer

LibreOffice Writer is a full-featured word processor with page and text-formatting
capabilities. Its interface is similar to interfaces for other major word processors. It also
includes some features that are usually found only in expensive desktop publishing
applications. Many of the LibreOffice Writer features apply also to other LibreOffice
modules.

5.1 What is New in Writer

Below is a list of new features:

Increased Document Protection
LibreOffice Writer and Calc now allow two levels of document protection. You
can normally save a document with a password that prevents unauthorized users
from reading the content, but also set a password to protect a document against
unwanted changes. This way, you can make the content of a document available for
reading to a selected group of people, while different group can both read and edit
it. This behavior is now compatible with Microsoft Word and Excel file protection.

Resetting Text to the Default Language
You can now reset the language of the text back to the default language using the
language status bar or with Tools > Language.

Word Count Dialog Enhanced
LibreOffice Writer now displays the number of characters both with and without
spaces.

New Title Page Option
Right-click an open document and select Title Page to insert a new title page of
the document with different formatting options. The document can contain several
title pages. You can, for example, specify to reset numberings after each inserted
title page.

5.2 Creating a New Document

There are two ways to create a new document:

To create a completely new document, click File > New > Text Document.



66 Start-Up

To use a standard format and predefined elements for your own documents, try a
wizard (a small utility that lets you make some basic initial decisions and then produces
a ready-made document from a template). For example, to create a business letter,
click File > Wizards > Letter. With the wizard's dialogs, you can create a basic
document that uses a standard format.

Enter text in the document window as desired. Use the Formatting toolbar or the Format
menu to adjust the appearance of the document. Use the File menu or the relevant
buttons in the toolbar to print and save your document. With the options under Insert,
add extra items to your document, such as a table, picture, or chart.

5.3 Customizing LibreOffice

With LibreOffice you can customize the default settings with the Format menu.

Below is a list of the most popular options available in most modules:

Customizing Character Settings
To set all character elements at the same time, select Format > Character.

Customizing Paragraph Settings
To format paragraphs, select Format > Paragraph and select the appropriate tabs
for making changes.

Customizing Alignment
To modify the alignment, select Format > Paragraph and choose the alignment you
want.

Inserting Headers and Footers
If you want to add headers and footers, click Insert and select either Header or
Footer.
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Inserting Special Characters
If you want to insert special characters, select Insert > Special Character.

Inserting Footnotes
If you want to insert footnotes, click Insert and select Footnote.

Inserting Columns
If you want to insert columns, click Insert and select Section. Then in the Columns
tab, specify the number of columns to use for the current section.

Inserting Indexes and Table of Contents
If you want to insert indexes or a table of contents, click Insert and select Indexes
and Tables.

The Object Toolbar offers additional text formatting options.

5.4 Using Master Documents

If you are working with a very large document (such as a book), you might find it easier
to manage the book with a master document, rather than keeping the book in a single
file. A master document enables you to quickly apply formatting changes to a large
document or to jump to each subdocument for editing.

A master document is a Writer document that serves as a container for multiple Writer
files. You can maintain chapters or other subdocuments as individual files collected in
the master document. Master documents are also useful if multiple people are working
on a document. You can separate each person’s relevant part of the document into
subdocuments, allowing multiple writers to work on their subdocuments at the same
time without the danger of overwriting each other’s work.

1 Click New > Master Document.
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or

Open an existing document and click File > Send > Create Master Document.

2 Insert subdocuments.

3 Click File Save.

The LibreOffice help files contain more complete information about working with
master documents. Look for the topic entitled Working with Master Documents and
Subdocuments.

5.5 Using Writer as HTML Editor

In addition to being a full-featured word processor, Writer also functions as an HTML
editor. Writer includes HTML tags that can be applied the same way as any other style
in a Writer document. You can view the document as it will appear online, or you can
directly edit the HTML code.

1 Click File > New > HTML Document.

2 Press F11 to open the Styles and Formatting window.

3 Click the arrow at the bottom of the Styles and Formatting window.

4 Select HTML Styles.

5 Create your HTML document, using the styles to tag your text.

6 Click File > Save As.

7 Select the location where you want to save your file, name the file, and select
HTML Document (.html) from the File Type list.

8 Click OK.

If you prefer to edit HTML code directly, or if you want to see the HTML code created
when you edited the HTML file as a Writer document, click View > HTML Source. In
HTML Source mode, the Formatting and Styles list is not available. The first time you
switch to HTML Source mode, you are prompted to save the file as HTML, if you have
not already done so.

5.6 Tables

You can include tabular data in the Writer, Impress and Draw module. Insert basic
tables directly into your document either with the following menus items or by using
the toolbar:

• Insert > Table,

• Table > Insert > Table,
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• or use the Table icon.

To enter data, select a cell with your mouse pointer and begin typing. To move around
cells, use the arrow keys. [→|] moves to the next cell, skipping over the contents of the
cell and [Shift] + [→|] moves backwards.

You can use Table menu or the Table toolbar to modify the table.

6 LibreOffice Calc
Calc is the LibreOffice spreadsheet and data-plotting module. Spreadsheets consist
of a number of sheets, containing cells which can be filled with elements like text,
numbers, or formulas. A formula can manipulate data from other cells to generate a
value for the cell into which it is inserted. Calc also allows you to define ranges, filter
and sort the data, or create charts from the data to present it graphically. By using
DataPilots, you can combine, analyze or compare larger amounts of data.

As with the entire LibreOffice suite, Calc can be used across a variety of platforms. It
provides a number of exchange formats (including export to PDF documents), and can
also read and save files in Microsoft Excel's format.
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6.1 What is New in Calc

Below is a list of new features for Calc:

Higher Number of Rows Per Calc Sheet
Calc spreadsheets now support 1 million rows instead of former 65,536 rows.

Charts Support Drawing Objects
The Chart functionality is enhanced and now supports drawing objects. The drawing
toolbar allows to insert simple shapes such as lines, rectangles and text objects,
and even complex shapes such as cubes, symbols, block arrows, flowcharts and
stars.

Intelligent Selection of Filter Area
The selection is now shrunk to the actually used data columns when enabling a
filter (AutoFilter, StandardFilter, AdvancedFilter). Users can select an entire row by
clicking on a row header and expect a filter to operate on the data below the selected
row. If one single row is selected the selection is shrunk to the actually used data
columns and then expanded over all contiguous data rows below. Selecting only a
portion of a row behaves similar by expanding the selected columns over the data
rows. If more than one entire row is selected, the area is shrunk to the actual used
data columns.

Colored Sheet Tabs
Each sheet in a Calc document can be assigned a color for its tab: Right-click on a
sheet tab and choose Tab color and choose the color of your choice.

6.2 Creating a New Document

Start LibreOffice and select File > New > Spreadsheet to create a new spreadsheet.
Access the individual sheets by clicking the respective tabs at the bottom of the window.

Enter data in the cells as desired. To adjust appearance, either use the Formatting
toolbar or the Format menu—or define styles. Use the File menu or the relevant buttons
in the toolbar to print and save your document.

6.3 Customizing LibreOffice Calc

Calc comes with a few built-in cell and page styles to improve the appearance of your
spreadsheets and reports. Although these built-in styles are adequate for many uses,
you will probably find it useful to create styles for your own frequently-used formatting
preferences.

Procedure 17 Creating a Style

1 Click Format > Styles and Formatting.

2 In the Styles and Formatting window, click one of the icons representing either
Paragraph Styles, Paragraph Styles, or Page Styles.



LibreOffice Quick Start  71

3 Right-click in the  Styles and Formatting window, then click New.

4 Specify a name for your style and use the various tabs to set the desired
formatting options.

5 Click OK.

Procedure 18 Modifying a Style

1 Click Format > Styles and Formatting.

2 In the Styles and Formatting window, click one of the icons representing either
Paragraph Styles, Paragraph Styles, or Page Styles.

3 Right-click the name of the style you want to change, then click Modify.

4 Change the desired formatting options.

5 Click OK.

7 Other LibreOffice Modules

Besides Writer and Calc, LibreOffice also includes the modules Impress, Base, Draw,
and Math. With these you can create presentations, design databases, draw up
graphics and diagrams, and create mathematical formulas.

7.1 Using Presentations with Impress

Use LibreOffice Impress to create presentations for screen display or printing, such
as slide shows or transparencies. If you have used other presentation software, you
can move comfortably to Impress, which works very similarly to other presentation
software.

Impress can open and save Microsoft PowerPoint presentations, which means you
can exchange presentations with PowerPoint users, as long as you save your
presentations in PowerPoint format.

Impress also allows you to use 3D transitions for your slides. Access the available
transitions by selecting Slide Show > Slide Transitions.

You can either create a brand new presentation (without any preformatted slides) or
use an existing template or presentation for your new document. Impress uses styles
and templates the same way other LibreOffice modules do. A wizard leads you through
the options available for creating new presentations.
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7.2 Using Databases with Base

LibreOffice includes a database module called Base. Use Base to design a database
to store many different kinds of information, from a simple address book or recipe file
to a sophisticated document management system.

Tables, forms, queries, and reports can be created manually or using convenient
wizards. For example, the Table Wizard contains a number of common fields for
business and personal use. A wizard guides you through the steps to create a new
database.

LibreOffice Base comes with several predefined database fields to help you create
a database. A wizard guides you through the steps to create a new database. The
following steps are specific to creating an address book using predefined fields, but
it should be easy to use the predefined fields for any of the built-in database options.
The process for creating a database can be broken into several subprocesses:

Procedure 19 Creating a Database

1 Click File > New > Database.

2 Select Create a new database and click Next.

3 Click Yes, register the database for me to make your database information
available to other LibreOffice modules, select both check boxes in the bottom
half of the dialog, then click Finish.

4 Browse to the directory where you want to save the database, specify a name
for the database, then click Save.

Procedure 20 Setting Up the Database Table

1 Click the Tables icon in the left pane and select Use Wizard to Create Table.

2 In the Table Wizard, click Personal.
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3 The Sample tables list changes to show the predefined tables for personal use.
If you had clicked Business, the list would contain predefined business tables.

In the Sample tables list, click Addresses. The available fields for the predefined
address book appear in the Available fields menu.

4 In the Available fields menu, click the fields you want to use in your address
book.

You can select one item at a time, or you can shift-click multiple items to select
them.

5 Click the single arrow icon to move the selected items to the Selected fields
menu.

To move all available fields to the Selected fields menu, click the double right-
arrow.

6 Use the arrow keys to adjust the order of the selected fields and click Finish.

The fields appear in the table and forms in the order in which they are listed.

7.3 Creating Graphics with Draw

Use LibreOffice Draw to create graphics and diagrams. You can save your drawings
in today’s most common formats and import them into any application that lets you
import graphics, including the other LibreOffice modules. You can also create Flash
versions of your drawings.

Procedure 21 Creating a Graphic

1 Click [Alt] + [F2] and enter oodraw to open LibreOffice Draw.

2 Use the toolbar at the bottom of the window to create a graphic.

3 Save the graphic.
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To embed an existing Draw graphic into an LibreOffice document, select Insert > Object
> OLE Object. Select Create from file and click Search to navigate to the Draw file to
insert. If you insert a file as OLE object, you can easily edit the object later by double-
clicking it.

Procedure 22 Opening Draw From Other LibreOffice Modules

One particularly useful feature of Draw is the ability to open it from other LibreOffice
modules so you can create a drawing that is automatically imported into your
document.

1 From an LibreOffice module (for example, from Writer), click Insert > Object >
OLE Object > LibreOffice 3.x Drawing > OK. This opens Draw.

2 Create your drawing.

3 Click in your document, outside the Draw frame.

The drawing is automatically inserted into your document.

7.4 Creating Mathematical Formulas with Math

It is usually difficult to include complex mathematical formulas in your documents. The
LibreOffice Math equation editor lets you create formulas using operators, functions,
and formatting assistants. You can then save those formulas as objects that can be
imported into other documents. Math functions can be inserted into other LibreOffice
documents like any other graphic object.

Using Math, you can enter your equation in three different ways:

• Type markup in the equation editor,

• Right-click on the equation editor and select the symbol from the context menu,

or

• Select a symbol from the Elements toolbox.

NOTE

Math is not a calculator. The functions it creates are graphical objects. Even if they
are imported into Calc, these functions cannot be evaluated.

8 For More Information
LibreOffice contains extensive online help. In addition, a large community of users and
developers support it. For more details, see the following links:

http://www.libreoffice.org/
The home page of the LibreOffice project.

http://www.libreoffice.org/
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http://openoffice.org/dev_docs/features/3.3
A list of all new features available with LibreOffice.

http://support.openoffice.org/index.html
Official LibreOffice support page, provides manuals and other documentation

http://www.taming-openoffice-org.com/
Taming LibreOffice: Books, news, tips and tricks.

http://documentation.LibreOffice/HOW_TO/index.html
Detailed HowTo's for various LibreOffice tasks, including how to create and use
templates.

http://openoffice.org/dev_docs/features/3.3
http://support.openoffice.org/index.html
http://www.taming-openoffice-org.com/
http://documentation.LibreOffice/HOW_TO/index.html




A Help and Troubleshooting

A.1 Help and Documentation
comes with various sources of information and documentation, many of which are
already integrated into your installed system.

Documentation in /usr/share/doc
This traditional help directory holds various documentation files and release
notes for your system. It contains also information of installed packages in
the subdirectory packages. Find more detailed information in Section A.1.1,
“Documentation Directory” (page 77).

Man Pages and Info Pages for Shell Commands
When working with the shell, you do not need to know the options of the commands
by heart. Traditionally, the shell provides integrated help by means of man pages
and info pages. Read more in Section A.1.2, “Man Pages” (page 79) and
Section A.1.3, “Info Pages” (page 80).

Desktop Help Centers
The help centers of both the KDE desktop (KDE help center) and the GNOME
desktop (Help) provide central access to the most important documentation
resources on your system in searchable form. These resources include online help
for installed applications, man pages, info pages, and the Novell/SUSE manuals
delivered with your product.

Separate Help Packages for Some Applications
When installing new software with YaST, the software documentation is installed
automatically (in most cases) and usually appears in the help center of your
desktop. However, some applications, such as GIMP, may have different online
help packages that can be installed separately with YaST and do not integrate into
the help centers.

A.1.1 Documentation Directory

 The traditional directory to find documentation on your installed Linux system is /
usr/share/doc . Usually, the directory contains information about the packages
installed on your system, plus release notes, manuals, and more.

NOTE: Contents Depends on Installed Packages

In the Linux world, many manuals and other kinds of documentation are available in
the form of packages, just like software. How much and which information you find in
/usr/share/docs  also depends on the (documentation) packages installed. If
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you cannot find the subdirectories mentioned here, check if the respective packages
are installed on your system and add them with YaST, if needed.

Novell/SUSE Manuals

  We provide HTML and PDF versions of our books in different languages. In
the manual subdirectory, find HTML versions of most of the Novell/SUSE manuals
available for your product. For an overview of all documentation available for your
product refer to the preface of the manuals.

If more than one language is installed, /usr/share/doc/manual  may contain
different language versions of the manuals. The HTML versions of the Novell/SUSE
manuals are also available in the help center of both desktops. For information on
where to find the PDF and HTML versions of the books on your installation media,
refer to the Release Notes. They are available on your installed system under /usr/
share/doc/release-notes/  or online at your product-specific Web page at
http://www.novell.com/documentation/ .

HOWTOs

 If the howto package is installed on your system, /usr/share/doc  also holds the
howto subdirectory, where you find additional documentation for many tasks relating
to the setup and operation of Linux software.

Package Documentation

 Under packages, find the documentation that is included in the software packages
installed on your system. For every package, a subdirectory /usr/share/doc/
packages/ packagename is created. It often contains README files for the
package and sometimes examples, configuration files, or additional scripts. The
following list introduces typical files to be found under /usr/share/doc/
packages . None of these entries are mandatory and many packages might just
include a few of them.

AUTHORS
List of the main developers.

BUGS
Known bugs or malfunctions. Might also contain a link to a Bugzilla Web page where
you can search all bugs.

CHANGES  ,  ChangeLog
Summary of changes from version to version. Usually interesting for developers,
because it is very detailed.

COPYING  ,  LICENSE
Licensing information.

FAQ
Question and answers collected from mailing lists or newsgroups.

http://www.novell.com/documentation/
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INSTALL
How to install this package on your system. As the package is already installed by
the time you get to read this file, you can safely ignore the contents of this file.

README, README.*
General information on the software. For example, for what purpose and how to
use it.

TODO
Things that are not implemented yet, but probably will be in the future.

MANIFEST
List of files with a brief summary.

NEWS
Description of what is new in this version.

A.1.2 Man Pages
Man pages are an essential part of any Linux system. They explain the usage of a
command and all available options and parameters. Man pages can be accessed with
man followed by the name of the command, for example, man ls.

Man pages are displayed directly in the shell. To navigate them, move up and down
with [Page ↑] and [Page ↓]. Move between the beginning and the end of a document
with [Home] and [End]. End this viewing mode by pressing [Q]. Learn more about the
man command itself with man man. Man pages are sorted in categories as shown in
Table A.1, “Man Pages—Categories and Descriptions” (page 79) (taken from the
man page for man itself).

Table A.1 Man Pages—Categories and Descriptions

Number Description

1 Executable programs or shell
commands

2 System calls (functions provided by the
Kernel)

3 Library calls (functions within program
libraries)

4 Special files (usually found in /dev)

5 File formats and conventions (/etc/
fstab )
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Number Description

6 Games

7 Miscellaneous (including macro
packages and conventions), for
example, man(7), groff(7)

8 System administration commands
(usually only for root)

9 Kernel routines (nonstandard)

Each man page consists of several parts labeled NAME, SYNOPSIS, DESCRIPTION,
SEE ALSO, LICENSING, and AUTHOR. There may be additional sections available
depending on the type of command.

A.1.3 Info Pages
Info pages are another important source of information on your system. Usually, they
are more detailed than man pages. To view the info page for a certain command, enter
info followed by the name of the command, for example, info ls. You can browse
an info page with a viewer directly in the shell and display the different sections, called
“nodes”. Use [Space] to move forward and [<—] to move backwards. Within a node,
you can also browse with [Page ↑] and [Page ↓] but only [Space] and [<—] will take you
also to the previous or subsequent node. Press [Q] to end the viewing mode. Not every
man page comes with an info page and vice versa.

A.1.4 Online Resources

 In addition to the online versions of the openSUSE manuals installed under /usr/
share/doc , you can also access the product-specific manuals and documentation
on the Web. For an overview of all documentation available for check out your product-
specific documentation Web page at http://doc.opensuse.org .

If you are searching for additional product-related information, you can also refer to
the following Web sites:

openSUSE Wiki
Detailed information about lots of different aspects of the openSUSE system can
be found in our Wiki at http://en.opensuse.org . You may also contribute
to each Wiki page and change or add new pages.

openSUSE Support Database
The openSUSE Support Database (SDB) can be found at http://

en.opensuse.org/Portal:Support_database . It features articles
written as solutions for technical problems with . They cover issues from installation
and configuration, to workarounds for bugs and missing features.

http://doc.opensuse.org
http://en.opensuse.org
http://en.opensuse.org/Portal:Support_database
http://en.opensuse.org/Portal:Support_database
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openSUSE Forums
There are several openSUSE forums where you can dive in on discussions about
openSUSE, or get support. See http://en.opensuse.org/openSUSE:
Forums_list  for a list.

KDE Documentation
Find documentation for many aspects of KDE suitable for users and administrators
at http://www.kde.org/documentation/ .

GNOME Documentation
Documentation for GNOME users, administrators and developers is available at
http://library.gnome.org/ .

The Linux Documentation Project
The Linux Documentation Project (TLDP) is run by a team of volunteers who write
Linux-related documentation (see http://www.tldp.org ). It's probably the
most comprehensive documentation resource for Linux. The set of documents
contains tutorials for beginners, but is mainly focused on experienced users and
professional system administrators. TLDP publishes HOWTOs, FAQs, and guides
(handbooks) under a free license. Parts of the documentation from TLDP is also
available on

You might also want to try general-purpose search engines. For example, you might
try the search terms Linux CD-RW help or OpenOffice file conversion
problem if you were having trouble with the CD burning or with OpenOffice.org
file conversion. Google™ also has a Linux-specific search engine at http://www
.google.com/linux  that you might find useful.

A.1.5 Support for

Useful support information for is available in a number of sources:

• Free installation support for retail box customer.

• Free community support http://en.opensuse.org/Communicate .

If you encounter problems with the installation or use of that you are unable to
solve, our experienced support staff can offer practical assistance with the free
installation support for registered releases. Nearly all common customer problems can
be eliminated quickly and competently. You can use the extensive support offered
through the community, as well.

Free Installation Support

Our free installation support is provided for a period of 90 days following the
activation of your registration code http://www.open-slx.com/register
or following the release of the next version. If you cannot find an answer to your
question in any of the available information sources, we will gladly provide assistance
for the following issues:

http://en.opensuse.org/openSUSE:Forums_list
http://en.opensuse.org/openSUSE:Forums_list
http://www.kde.org/documentation/
http://library.gnome.org/
http://www.tldp.org
http://www.google.com/linux
http://www.google.com/linux
http://en.opensuse.org/Communicate
http://www.open-slx.com/register
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• Installation on a typical home user system or laptop equipped with a single
processor, at least 512 MB RAM (1024 MB recommended), and 8 GB of free hard
disk space.

• Resizing of one Windows partition that occupies the entire hard disk.

• Dual-boot installation with Windows, limited to Linux Support.

• Installation of a local ATAPI CD or DVD drive.

• Installation from a remote CD/DVD drive

• Installation on the first or second hard disk in an IDE-only system (/dev/sda  or
/dev/sdb ) or supported S-ATA system, excluding RAID.

• Integration of a standard keyboard and standard mouse.

• Configuration of the graphical user interface (without the hardware acceleration
feature of the graphics card).

• Installation of the boot manager in the MBR of the first hard disk without modifying
the BIOS mapping.

• Setup of Internet access with a supported PCI ISDN card or external serial modem
(not USB). Conversely, setup of DSL based on PPPoE with a supported NIC.

• Basic configuration of a supported WLAN adapter.

• Basic configuration of an ALSA-supported PCI sound card.

• Basic configuration of a locally-attached compatible printer with YaST.

• Basic configuration of an IDE CD writer for use with k3b (CD burning application)
without changing the jumper setting.

• Configuration of a supported PCI ethernet card for LAN access with either DHCP
(client) or static IP. This does not include the configuration of the LAN or any other
computers or network components. It also does not cover the configuration of the
computer as a router. Fault analysis is limited to checking for proper loading of the
kernel module and the correct local network settings.

• Configuration of an e-mail client (Evolution and KMail) for collecting mail from a
POP3 account. Fault analysis is limited to checking for proper settings in the e-
mail client.

• Support for the package selection KDE Desktop or GNOME Desktop.

• Upgrade from the previous version of the product.

• Kernel updates (only official Novell update RPMs).

• Installation of bug fixes and security updates from the official update server using
online update or the manual method.
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For a detailed listing of the subjects covered by the free installation support, check
http://www.open-slx.com/support .

In case you are not sure if your support is covered, please do not hesitate to give us
a call. We are happy to assist.

Contact Information for Free Installation Support

Reach our support staff under the following links and phone numbers. Our installation
support is offered through call back. After your problem description our staff either tries
to call you back in the next 2 hours or arrange a time for a call back. Please register your
product at http://www.open-slx.com/register  prior to your support
request.

• http://support.open-slx.com/eService

• United States and Canada: +1-404-5854-269

• Germany, Austria, Switzerland: Phone: +49 (0)911-8946-0303

• UK: +44-2030-025-943

• All other countries (English only): please see http://www.open-slx
.com/support .

For the most recent contact information, refer to http://www.open-slx.com/
support .

Important Notes

1. Free installation support is offered to customers with a valid and activated
registration code. You can activate your registration code at http://www
.open-slx.com/register/ .

2. The registration code is not transferable to another person.

3. The free support covers the initial installation on one computer. Refer to our Web
site for further information http://www.open-slx.com/support .

Contact Recommendations

We recommend using http://support.open-slx.com/eService  to
open a service request and to provide us with the relevant information like problem
description and log files. It helps us to avoid misspelled commands, links, or directory
names, which often cause frustrating problems and are particularly common during
phone conversations. You will receive a reply soon, providing a practical solution.

Preparing a Support Request

We endeavor to help you as quickly and precisely as possible. The effort and time
needed is considerably reduced if the question is formulated clearly. Please have
answers to the following questions ready before contacting us:

http://www.open-slx.com/support
http://www.open-slx.com/register
http://support.open-slx.com/eService
http://www.open-slx.com/support
http://www.open-slx.com/support
http://www.open-slx.com/support
http://www.open-slx.com/support
http://www.open-slx.com/register/
http://www.open-slx.com/register/
http://www.open-slx.com/support
http://support.open-slx.com/eService
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1. Which program and version are you using? During which process does the problem
occur?

2. What exactly is the problem? Try to describe the error as precisely as possible,
using phrases with words such as when (for example, “When X is pressed, this
error appears”).

3. What hardware do you use (graphics card, monitor, printer, ISDN card, etc.)? You
can get this information from the YaST Hardware Information module.

Detailed documentation can be found in manuals, online help, and the Support
Database. This comprehensive documentation of gives guidance to solve a variety
of problems. The SUSE Help Center on your desktop provides additional information
about installed packages, the vital HOWTOs, and info pages.

You can access the latest Support Database articles online at http://www
.open-slx.com/support  or access the community Support Database at
http://en.opensuse.org/Portal:Support_database . The Support
Database, one of the most frequently used databases in the Linux world, offers our
customers a wealth of analysis and solution approaches. You can retrieve tested
solutions using the keyword search, history function, or version-dependent search.

A.2 Common Problems and Their Solutions

This chapter describes a range of potential problems and their solutions. Even if your
situation is not precisely listed here, there may be one similar enough to offer hints to
the solution of your problem.

A.2.1 Finding and Gathering Information

Linux reports things in a very detailed way. There are several places to look when you
encounter problems with your system, most of which are standard to Linux systems in
general, and some of which are relevant to systems. The two most important system
logs are /var/log/boot.msg  and /var/log/messages .

A list of the most frequently checked log files follows with the description of their typical
purpose. Paths containing ~  refer to the current user's home directory.

Table A.2 Log Files

Log File Description

~/.xsession-errors Messages from the desktop
applications currently running.

/var/log/apparmor/ Log files from AppArmor, see
Part “Confining Privileges with Novell

http://www.open-slx.com/support
http://www.open-slx.com/support
http://en.opensuse.org/Portal:Support_database
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Log File Description

AppArmor” (↑Security Guide) for
detailed information.

/var/log/boot.msg Messages from the kernel reported
during the boot process.

/var/log/mail.* Messages from the mail system.

/var/log/messages Ongoing messages from the kernel
and system log daemon (when
running).

/var/log/NetworkManager Log file from NetworkManager
to collect problems with network
connectivity

/var/log/samba/ Directory containing Samba server and
client log messages.

/var/log/SaX.log Hardware messages from the SaX
display and KVM system.

/var/log/warn All messages from the kernel and
system log daemon with the “warning”
level or higher.

/var/log/wtmp Binary file containing user login records
for the current machine session. View it
with last.

/var/log/Xorg.*.log Various start-up and runtime logs from
the X Window system. It is useful for
debugging failed X start-ups.

/var/log/YaST2/ Directory containing YaST's actions
and their results.

/var/log/zypper.log Log file of zypper.

Apart from log files, your machine also supplies you with information about the running
system. See Table A.3: System Information With the /proc File System
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Table A.3 System Information With the /proc File System

File Description

/proc/cpuinfo Contains processor information,
including its type, make, model, and
performance.

/proc/dma Shows which DMA channels are
currently being used.

/proc/interrupts Shows which interrupts are in use, and
how many of each have been in use.

/proc/iomem Displays the status of I/O (input/output)
memory.

/proc/ioports Shows which I/O ports are in use at the
moment.

/proc/meminfo Displays memory status.

/proc/modules Displays the individual modules.

/proc/mounts Displays devices currently mounted.

/proc/partitions Shows the partitioning of all hard disks.

/proc/version Displays the current version of Linux.

Apart from the /proc file system, the Linux kernel exports information with the
sysfs module, an in-memory filesystem. This module represents kernel objects, their
attributes and relationships. For more information about sysfs, see the context of
udev in Chapter 20, Dynamic Kernel Device Management with udev (↑Reference).
Table A.4 contains an overview of the most common directories under /sys.

Table A.4 System Information With the /sys File System

File Description

/sys/block Contains subdirectories for each block
device discovered in the system.
Generally, these are mostly disk type
devices.
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File Description

/sys/bus Contains subdirectories for each
physical bus type.

/sys/class Contains subdirectories grouped
together as a functional types of
devices (like graphics, net, printer, etc.)

/sys/device Contains the global device hierarchy.

Linux comes with a number of tools for system analysis and monitoring. See Chapter 2,
System Monitoring Utilities (↑System Analysis and Tuning Guide) for a selection of the
most important ones used in system diagnostics.

Each of the following scenarios begins with a header describing the problem followed
by a paragraph or two offering suggested solutions, available references for more
detailed solutions, and cross-references to other scenarios that are related.

A.2.2 Installation Problems

Installation problems are situations when a machine fails to install. It may fail entirely
or it may not be able to start the graphical installer. This section highlights some of the
typical problems you may run into, and offers possible solutions or workarounds for
these kinds of situations.

Checking Media
If you encounter any problems using the installation media, check the integrity of your
installation media. Boot from the media and choose Check Installation Media from the
boot menu. In a running system, start YaST and choose Software > Media Check.
Media problems are more probable with the media you burn yourself. Burning the
media at a low speed (4x) helps avoiding problems.

Hardware Information
Display detected hardware and technical data using Hardware > Hardware Information
in YaST. Click any node of the tree for more information about a device. This module
is especially useful, when submitting a support request for which you need information
about your hardware.

Save the displayed hardware information to a file by clicking Save to File. Select the
desired directory and filename then click Save to create the file.

No Bootable DVD Drive Available

If your computer does not contain a bootable DVD-ROM drive or if the one you have is
not supported by Linux, there are several options you can install your machine without
a built-in DVD drive:
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Using an External Boot Device
If it is supported by your BIOS and the installation kernel, boot from external DVD
drives or USB storage devices.

Network Boot via PXE
If a machine lacks a DVD drive, but provides a working ethernet connection, perform
a completely network-based installation. See Section “Remote Installation via VNC
—PXE Boot and Wake on LAN” (Chapter 2, Remote Installation, ↑Reference) and
Section “Remote Installation via SSH—PXE Boot and Wake on LAN” (Chapter 2,
Remote Installation, ↑Reference) for details.

External Boot Devices

Linux supports most existing DVD drives. If the system has neither a DVD drive nor
a floppy disk, it is still possible that an external DVD drive, connected through USB,
FireWire, or SCSI, can be used to boot the system. This depends mainly on the
interaction of the BIOS and the hardware used. Sometimes a BIOS update may help
if you encounter problems.

When installing from a KDE or GNOME Live CD, you can also create a “Live USB stick”
to boot from. Refer to http://en.opensuse.org/Live_USB_stick  for
detailed instructions.

Booting from Installation Media Fails

One reason why a machine does not boot the installation media can be an incorrect
boot sequence setting in BIOS. The BIOS boot sequence must have DVD drive set
as the first entry for booting. Otherwise the machine would try to boot from another
medium, typically the hard disk. Guidance for changing the BIOS boot sequence
can be found the documentation provided with your motherboard, or in the following
paragraphs.

The BIOS is the software that enables the very basic functions of a computer.
Motherboard vendors provide a BIOS specifically made for their hardware. Normally,
the BIOS setup can only be accessed at a specific time—when the machine is booting.
During this initialization phase, the machine performs a number of diagnostic hardware
tests. One of them is a memory check, indicated by a memory counter. When the
counter appears, look for a line, usually below the counter or somewhere at the bottom,
mentioning the key to press to access the BIOS setup. Usually the key to press is one
of [Del], [F1], or [Esc]. Press this key until the BIOS setup screen appears.

Procedure A.1 Changing the BIOS Boot Sequence

1 Enter the BIOS using the proper key as announced by the boot routines and
wait for the BIOS screen to appear.

2 To change the boot sequence in an AWARD BIOS, look for the BIOS
FEATURES SETUP entry. Other manufacturers may have a different name for
this, such as ADVANCED CMOS SETUP. When you have found the entry,
select it and confirm with [Enter].

http://en.opensuse.org/Live_USB_stick
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3 In the screen that opens, look for a subentry called BOOT SEQUENCE or BOOT
ORDER. The boot sequence looks something like C,A or A,C. In the former
case, the machine first searches the hard disk (C) then the floppy drive (A) to
find a bootable medium. Change the settings by pressing [PgUp] or [PgDown]
until the sequence is A,CDROM,C.

4 Leave the BIOS setup screen by pressing [Esc]. To save the changes, select
SAVE & EXIT SETUP, or press [F10]. To confirm that your settings should be
saved, press [Y].

Procedure A.2 Changing the Boot Sequence in a SCSI BIOS (Adaptec Host
Adapter)

1 Open the setup by pressing [Ctrl] + [A].

2 Select Disk Utilities. The connected hardware components are now displayed.

Make note of the SCSI ID of your DVD drive.

3 Exit the menu with [Esc].

4 Open Configure Adapter Settings. Under Additional Options, select Boot Device
Options and press [Enter].

5 Enter the ID of the DVD drive and press [Enter] again.

6 Press [Esc] twice to return to the start screen of the SCSI BIOS.

7 Exit this screen and confirm with Yes to boot the computer.

Regardless of what language and keyboard layout your final installation will be using,
most BIOS configurations use the US keyboard layout as depicted in the following
figure: 

Figure A.1 US Keyboard Layout

Fails to Boot

Some hardware types, mainly very old or very recent ones, fail to install. In many cases,
this may happen because support for this type of hardware is missing in the installation
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kernel, or due to certain functionality included in this kernel, such as ACPI, that can
still cause problems on some hardware.

If your system fails to install using the standard Installation mode from the first
installation boot screen, try the following:

1 With the DVD still in the drive, reboot the machine with [Ctrl] + [Alt] + [Del] or
using the hardware reset button.

2 When the boot screen appears, press [F5], use the arrow keys of your keyboard
to navigate to No ACPI and press [Enter] to launch the boot and installation
process. This option disables the support for ACPI power management
techniques.

3 Proceed with the installation as described in Chapter 1, Installation with YaST
(↑Reference).

If this fails, proceed as above, but choose Safe Settings instead. This option disables
ACPI and DMA support. Most hardware will boot with this option.

If both of these options fail, use the boot options prompt to pass any additional
parameters needed to support this type of hardware to the installation kernel.
For more information about the parameters available as boot options, refer to the
kernel documentation located in /usr/src/linux/Documentation/kernel
-parameters.txt .

TIP: Obtaining Kernel Documentation

Install the kernel-source package to view the kernel documentation.

There are various other ACPI-related kernel parameters that can be entered at the
boot prompt prior to booting for installation:

acpi=off
This parameter disables the complete ACPI subsystem on your computer. This may
be useful if your computer cannot handle ACPI at all or if you think ACPI in your
computer causes trouble.

acpi=force
Always enable ACPI even if your computer has an old BIOS dated before the year
2000. This parameter also enables ACPI if it is set in addition to acpi=off.

acpi=noirq
Do not use ACPI for IRQ routing.

acpi=ht
Run only enough ACPI to enable hyper-threading.

acpi=strict
Be less tolerant of platforms that are not strictly ACPI specification compliant.
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pci=noacpi
Disable PCI IRQ routing of the new ACPI system.

pnpacpi=off
This option is for serial or parallel problems when your BIOS setup contains wrong
interrupts or ports.

notsc
Disable the time stamp counter. This option can be used to work around timing
problems on your systems. It is a recent feature, if you see regressions on your
machine, especially time related or even total hangs, this option is worth a try.

nohz=off
Disable the nohz feature. If your machine hangs, this option may help. Otherwise
it is of no use.

Once you have determined the right parameter combination, YaST automatically writes
them to the boot loader configuration to make sure that the system boots properly next
time.

If unexplainable errors occur when the kernel is loaded or during the installation, select
Memory Test in the boot menu to check the memory. If Memory Test returns an error,
it is usually a hardware error.

Fails to Launch Graphical Installer

After you insert the medium into your drive and reboot your machine, the installation
screen comes up, but after you select Installation, the graphical installer does not start.

There are several ways to deal with this situation:

• Try to select another screen resolution for the installation dialogs.

• Select Text Mode for installation.

• Do a remote installation via VNC using the graphical installer.

Procedure A.3 Change Screen Resolution for Installation

1 Boot for installation.

2 Press [F3] to open a menu from which to select a lower resolution for installation
purposes.

3 Select Installation and proceed with the installation as described in Chapter 1,
Installation with YaST (↑Reference).

Procedure A.4 Installation in Text Mode

1 Boot for installation.

2 Press [F3] and select Text Mode.
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3 Select Installation and proceed with the installation as described in Chapter 1,
Installation with YaST (↑Reference).

Procedure A.5 VNC Installation

1 Boot for installation.

2 Enter the following text at the boot options prompt:

vnc=1 vncpassword=some_password

Replace some_password with the password to use for VNC installation.

3 Select Installation then press [Enter] to start the installation .

Instead of starting right into the graphical installation routine, the system
continues to run in a text mode, then halts, displaying a message containing the
IP address and port number at which the installer can be reached via a browser
interface or a VNC viewer application.

4 If using a browser to access the installer, launch the browser and enter the
address information provided by the installation routines on the future machine
and hit [Enter]:

http://ip_address_of_machine:5801

A dialog opens in the browser window prompting you for the VNC password.
Enter it and proceed with the installation as described in Chapter 1, Installation
with YaST (↑Reference).

IMPORTANT

Installation via VNC works with any browser under any operating system,
provided Java support is enabled.

Provide the IP address and password to your VNC viewer when prompted. A
window opens, displaying the installation dialogs. Proceed with the installation
as usual.

Only Minimalistic Boot Screen Started

You inserted the medium into the drive, the BIOS routines are finished, but the system
does not start with the graphical boot screen. Instead it launches a very minimalistic
text-based interface. This may happen on any machine not providing sufficient graphics
memory for rendering a graphical boot screen.

Although the text boot screen looks minimalistic, it provides nearly the same
functionality as the graphical one:

Boot Options
Unlike the graphical interface, the different boot options cannot be selected using
the cursor keys of your keyboard. The boot menu of the text mode boot screen
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offers some keywords to enter at the boot prompt. These keywords map to the
options offered in the graphical version. Enter your choice and hit [Enter] to launch
the boot process.

Custom Boot Options
After selecting a boot option, enter the appropriate keyword at the boot prompt
or enter some custom boot options as described in Section “Fails to Boot”
(page 89). To launch the installation process, press [Enter].

Screen Resolutions
Use the F keys to determine the screen resolution for installation. If you need to
boot in text mode, choose [F3].

A.2.3 Boot Problems

Boot problems are situations when your system does not boot properly (does not boot
to the expected runlevel and login screen).

Fails to Load the GRUB Boot Loader

If the hardware is functioning properly, it is possible that the boot loader is corrupted
and Linux cannot start on the machine. In this case, it is necessary to repair the boot
loader. To do so, you need start the Rescue System as described in Section A.2.7,
“Recovering a Corrupted System” (page 106) and follow the instructions at Section
“Modifying and Reinstalling the Boot Loader” (page 109).

Other reasons for the machine not booting may be BIOS-related:

BIOS Settings
Check your BIOS for references to your hard drive. GRUB may simply not be started
if the hard drive itself cannot be found with the current BIOS settings.

BIOS Boot Order
Check whether your system's boot order includes the hard disk. If the hard disk
option was not enabled, your system may install properly, but fails to boot when
access to the hard disk is required.

No Graphical Login

If the machine comes up, but does not boot into the graphical login manager, anticipate
problems either with the choice of the default runlevel or the configuration of the X
Window System. To check the runlevel configuration, log in as the root user and check
whether the machine is configured to boot into runlevel 5 (graphical desktop). A quick
way to check this is to examine the contents of /etc/inittab , as follows:

tux@mercury:~> grep "id:" /etc/inittab 
id:5:initdefault:

The returned line indicates that the machine's default runlevel (initdefault) is set
to 5 and that it should boot to the graphical desktop. If the runlevel is set to any other
number, use the YaST Runlevel Editor module to set it to 5.
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IMPORTANT

Do not edit the runlevel configuration manually. Otherwise SuSEconfig (run by
YaST) will overwrite these changes on its next run. If you need to make manual
changes here, disable future SuSEconfig changes by setting CHECK_INITTAB in
/etc/sysconfig/suseconfig  to no.

If the runlevel is set to 5, your desktop or X Windows software is probably misconfigured
or corrupted. Examine the log files at /var/log/Xorg.*.log  for detailed
messages from the X server as it attempted to start. If the desktop fails during start, it
may log error messages to /var/log/messages . If these error messages hint at
a configuration problem in the X server, try to fix these issues. If the graphical system
still does not come up, consider reinstalling the graphical desktop.

TIP: Starting X Window System Manually

One quick test: the startx command should force the X Window System to start
with the configured defaults if the user is currently logged in on the console. If that
does not work, it should log errors to the console.

A.2.4 Login Problems

Login problems are those where your machine does, in fact, boot to the expected
welcome screen or login prompt, but refuses to accept the username and password,
or accepts them but then does not behave properly (fails to start the graphic desktop,
produces errors, drops to a command line, etc.).

Valid Username and Password Combinations Fail

This usually occurs when the system is configured to use network authentication or
directory services and, for some reason, is unable to retrieve results from its configured
servers. The root user, as the only local user, is the only user that can still log in to
these machines. The following are some common reasons why a machine appears
functional but is unable to process logins correctly:

• The network is not working. For further directions on this, turn to Section A.2.5,
“Network Problems” (page 99).

• DNS is not working at the moment (which prevents GNOME or KDE from working
and the system from making validated requests to secure servers). One indication
that this is the case is that the machine takes an extremely long time to respond
to any action. Find more information about this topic in Section A.2.5, “Network
Problems” (page 99).

• If the system is configured to use Kerberos, the system's local time may have
drifted past the accepted variance with the Kerberos server time (this is typically
300 seconds). If NTP (network time protocol) is not working properly or local NTP
servers are not working, Kerberos authentication ceases to function because it
depends on common clock synchronization across the network.
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• The system's authentication configuration is misconfigured. Check the PAM
configuration files involved for any typographical errors or misordering of
directives. For additional background information about PAM and the syntax of the
configuration files involved, refer to Chapter 2, Authentication with PAM (↑Security
Guide).

• The home partition is encrypted. Find more information about this topic in Section
“Login to Encrypted Home Partition Fails” (page 97).

In all cases that do not involve external network problems, the solution is to reboot the
system into single-user mode and repair the configuration before booting again into
operating mode and attempting to log in again. To boot into single-user mode:

1 Reboot the system. The boot screen appears, offering a prompt.

2 Enter 1 at the boot prompt to make the system boot into single-user mode.

3 Enter the username and password for root.

4 Make all the necessary changes.

5 Boot into the full multiuser and network mode by entering telinit 5 at the
command line.

Valid Username and Password Not Accepted

This is by far the most common problem users encounter, because there are many
reasons this can occur. Depending on whether you use local user management and
authentication or network authentication, login failures occur for different reasons.

Local user management can fail for the following reasons:

• The user may have entered the wrong password.

• The user's home directory containing the desktop configuration files is corrupted
or write protected.

• There may be problems with the X Window System authenticating this particular
user, especially if the user's home directory has been used with another Linux
distribution prior to installing the current one.

To locate the reason for a local login failure, proceed as follows:

1 Check whether the user remembered his password correctly before you start
debugging the whole authentication mechanism. If the user may not remember
his password correctly, use the YaST User Management module to change the
user's password. Pay attention to the [Caps Lock] key and unlock it, if necessary.

2 Log in as root and check /var/log/messages  for error messages of the
login process and of PAM.

3 Try to log in from a console (using [Ctrl] + [Alt] + [F1]). If this is successful,
the blame cannot be put on PAM, because it is possible to authenticate this
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user on this machine. Try to locate any problems with the X Window System
or the desktop (GNOME or KDE). For more information, refer to Section
“Login Successful but GNOME Desktop Fails” (page 98) and Section “Login
Successful but KDE Desktop Fails” (page 98).

4 If the user's home directory has been used with another Linux distribution,
remove the Xauthority file in the user's home. Use a console login via [Ctrl]
+ [Alt] + [F1] and run rm .Xauthority as this user. This should eliminate X
authentication problems for this user. Try graphical login again.

5 If graphical login still fails, do a console login with [Ctrl] + [Alt] + [F1]. Try to start
an X session on another display—the first one (:0) is already in use:

startx -- :1

This should bring up a graphical screen and your desktop. If it does not, check
the log files of the X Window System (/var/log/Xorg. displaynumber

.log ) or the log file for your desktop applications (.xsession-errors  in
the user's home directory) for any irregularities.

6 If the desktop could not start because of corrupt configuration files, proceed with
Section “Login Successful but GNOME Desktop Fails” (page 98) or Section
“Login Successful but KDE Desktop Fails” (page 98).

The following are some common reasons why network authentication for a particular
user may fail on a specific machine:

• The user may have entered the wrong password.

• The username exists in the machine's local authentication files and is also
provided by a network authentication system, causing conflicts.

• The home directory exists but is corrupt or unavailable. Perhaps it is write
protected or is on a server that is inaccessible at the moment.

• The user does not have permission to log in to that particular host in the
authentication system.

• The machine has changed hostnames, for whatever reason, and the user does
not have permission to log in to that host.

• The machine cannot reach the authentication server or directory server that
contains that user's information.

• There may be problems with the X Window System authenticating this particular
user, especially if the user's home has been used with another Linux distribution
prior to installing the current one.

To locate the cause of the login failures with network authentication, proceed as follows:

1 Check whether the user remembered their password correctly before you start
debugging the whole authentication mechanism.
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2 Determine the directory server which the machine relies on for authentication
and make sure that it is up and running and properly communicating with the
other machines.

3 Determine that the user's username and password work on other machines to
make sure that his authentication data exists and is properly distributed.

4 See if another user can log in to the misbehaving machine. If another user can
log in without difficulty or if root can log in, log in and examine the /var/log/
messages  file. Locate the time stamps that correspond to the login attempts
and determine if PAM has produced any error messages.

5 Try to log in from a console (using [Ctrl] + [Alt] + [F1]). If this is successful, the
problem is not with PAM or the directory server on which the user's home is
hosted, because it is possible to authenticate this user on this machine. Try to
locate any problems with the X Window System or the desktop (GNOME or
KDE). For more information, refer to Section “Login Successful but GNOME
Desktop Fails” (page 98) and Section “Login Successful but KDE Desktop
Fails” (page 98).

6 If the user's home directory has been used with another Linux distribution,
remove the Xauthority file in the user's home. Use a console login via [Ctrl]
+ [Alt] + [F1] and run rm .Xauthority as this user. This should eliminate X
authentication problems for this user. Try graphical login again.

7 If graphical login still fails, do a console login with [Ctrl] + [Alt] + [F1]. Try to start
an X session on another display—the first one (:0) is already in use:

startx -- :1

This should bring up a graphical screen and your desktop. If it does not, check
the log files of the X Window System (/var/log/Xorg. displaynumber

.log ) or the log file for your desktop applications (.xsession-errors  in
the user's home directory) for any irregularities.

8 If the desktop could not start because of corrupt configuration files, proceed with
Section “Login Successful but GNOME Desktop Fails” (page 98) or Section
“Login Successful but KDE Desktop Fails” (page 98).

Login to Encrypted Home Partition Fails
It is recommended to use an encrypted home partition for laptops. If you cannot log in
to your laptop, the reason is usually simple: your partition could not be unlocked.

During the boot time, you have to enter the passphrase to unlock your encrypted
partition. If you do not enter it, the boot process continues, leaving the partition locked.

To unlock your encrypted partition, proceed as follows:

1 Switch to the text console with [Ctrl] + [Alt] + [F1].

2 Become root.
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3 Restart the unlocking process again with:

/etc/init.d/boot.crypto restart

4 Enter your passphrase to unlock your encrypted partition.

5 Exit the text console and switch back to the login screen with [Alt] + [F7].

6 Log in as usual.

Login Successful but GNOME Desktop Fails

If this is the case, it is likely that your GNOME configuration files have become
corrupted. Some symptoms may include the keyboard failing to work, the screen
geometry becoming distorted, or even the screen coming up as a bare gray field. The
important distinction is that if another user logs in, the machine works normally. It is
then likely that the problem can be fixed relatively quickly by simply moving the user's
GNOME configuration directory to a new location, which causes GNOME to initialize
a new one. Although the user is forced to reconfigure GNOME, no data is lost.

1 Switch to a text console by pressing [Ctrl] + [Alt] + [F1].

2 Log in with your user name.

3 Move the user's GNOME configuration directories to a temporary location:

mv .gconf  .gconf-ORIG-RECOVER
mv .gnome2 .gnome2-ORIG-RECOVER

4 Log out.

5 Log in again, but do not run any applications.

6 Recover your individual application configuration data (including the Evolution
e-mail client data) by copying the ~/.gconf-ORIG-RECOVER/apps/
directory back into the new ~/.gconf  directory as follows:

cp -a .gconf-ORIG-RECOVER/apps .gconf/

If this causes the login problems, attempt to recover only the critical application
data and reconfigure the remainder of the applications.

Login Successful but KDE Desktop Fails

There are several reasons why a KDE desktop would not allow users to login.
Corrupted cache data can cause login problems as well as corrupt KDE desktop
configuration files.

Cache data is used at desktop start-up to increase performance. If this data is
corrupted, start-up is slowed down or fails entirely. Removing them forces the desktop
start-up routines to start from scratch. This takes more time than a normal start-up, but
data is intact after this and the user can login.
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To remove the cache files of the KDE desktop, issue the following command as root:
rm -rf /tmp/kde-user /tmp/ksocket-user

Replace user with your username. Removing these two directories just removes the
corrupted cache files. No real data is harmed using this procedure.

Corrupted desktop configuration files can always be replaced with the initial
configuration files. If you want to recover the user's adjustments, carefully copy them
back from their temporary location after the configuration has been restored, using the
default configuration values.

To replace a corrupted desktop configuration with the initial configuration values,
proceed as follows:

1 Switch to a text console by pressing [Ctrl] + [Alt] + [F1].

2 Log in with your username.

3 Move the KDE configuration directory and the .skel  files to a temporary
location:

• For KDE3 use these commands:
mv .kde  .kde-ORIG-RECOVER 
mv .skel .skel-ORIG-RECOVER

• For KDE4 use these commands:
mv .kde4  .kde4-ORIG-RECOVER 
mv .skel .skel-ORIG-RECOVER

4 Log out.

5 Log in again.

6 After the desktop has started successfully, copy the user's own configurations
back into place:
cp -a KDEDIR/share .kde/share

Replace KDEDIR with the directory from Step 3 (page 99).

IMPORTANT

If the user's own adjustments caused the login to fail and continue to do
so, repeat the procedure as described above, but do not copy the .kde/
share  directory.

A.2.5 Network Problems

Many problems of your system may be network-related, even though they do not seem
to be at first. For example, the reason for a system not allowing users to log in may be
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a network problem of some kind. This section introduces a simple check list you can
apply to identify the cause of any network problem encountered.

Procedure A.6 How to Identify Network Problems

When checking the network connection of your machine, proceed as follows:

1 If you use an ethernet connection, check the hardware first. Make sure that your
network cable is properly plugged into your computer and router (or hub, etc.).
The control lights next to your ethernet connector are normally both be active.

If the connection fails, check whether your network cable works with another
machine. If it does, your network card causes the failure. If hubs or switches
are included in your network setup, they may be faulty, as well.

2 If using a wireless connection, check whether the wireless link can be
established by other machines. If not, contact the wireless network's
administrator.

3 Once you have checked your basic network connectivity, try to find out which
service is not responding. Gather the address information of all network servers
needed in your setup. Either look them up in the appropriate YaST module
or ask your system administrator. The following list gives some of the typical
network servers involved in a setup together with the symptoms of an outage.

DNS (Name Service)
A broken or malfunctioning name service affects the network's functionality
in many ways. If the local machine relies on any network servers for
authentication and these servers cannot be found due to name resolution
issues, users would not even be able to log in. Machines in the network
managed by a broken name server would not be able to “see” each other
and communicate.

NTP (Time Service)
A malfunctioning or completely broken NTP service could affect Kerberos
authentication and X server functionality.

NFS (File Service)
If any application needs data stored in an NFS mounted directory, it will not
be able to start or function properly if this service was down or misconfigured.
In the worst case scenario, a user's personal desktop configuration would
not come up if their home directory containing the .gconf  or .kde
subdirectories could not be found due to a faulty NFS server.

Samba (File Service)
If any application needs data stored in a directory on a faulty Samba server,
it will not be able to start or function properly.

NIS (User Management)
If your system relies on a faulty NIS server to provide the user data, users
will not be able to log in to this machine.
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LDAP (User Management)
If your system relies on a faulty LDAP server to provide the user data, users
will not be able to log in to this machine.

Kerberos (Authentication)
Authentication will not work and login to any machine fails.

CUPS (Network Printing)
Users cannot print.

4 Check whether the network servers are running and whether your network setup
allows you to establish a connection:

IMPORTANT

The debugging procedure described below only applies to a simple network
server/client setup that does not involve any internal routing. It assumes
both server and client are members of the same subnet without the need for
additional routing.

4a Use ping IP address or hostname (replace hostname with
the hostname of the server) to check whether each one of them is up
and responding to the network. If this command is successful, it tells
you that the host you were looking for is up and running and that the
name service for your network is configured correctly.

If ping fails with destination host unreachable, either your
system or the desired server is not properly configured or down.
Check whether your system is reachable by running ping IP

address or your_hostname  from another machine. If you can
reach your machine from another machine, it is the server that is not
running at all or not configured correctly.

If ping fails with unknown host, the name service is not configured
correctly or the hostname used was incorrect. For further checks on
this matter, refer to Step 4b (page 101). If ping still fails, either your
network card is not configured correctly or your network hardware
is faulty.

4b Use host hostname to check whether the hostname of the server
you are trying to connect to is properly translated into an IP address
and vice versa. If this command returns the IP address of this host,
the name service is up and running. If the host command fails,
check all network configuration files relating to name and address
resolution on your host:

/etc/resolv.conf
This file is used to keep track of the name server and domain you
are currently using. It can be modified manually or automatically
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adjusted by YaST or DHCP. Automatic adjustment is preferable.
However, make sure that this file has the following structure and
all network addresses and domain names are correct:

search fully_qualified_domain_name
nameserver ipaddress_of_nameserver

This file can contain more than one name server address, but
at least one of them must be correct to provide name resolution
to your host. If needed, adjust this file using the YaST Network
Setting module (Hostname/DNS tab).

If your network connection is handled via DHCP, enable DHCP
to change hostname and name service information by selecting
Change Hostname via DHCP and Update Name Servers and
Search List via DHCP in the YaST DNS and Hostname module.

/etc/nsswitch.conf
This file tells Linux where to look for name service information.
It should look like this:

 ...
hosts: files dns
networks: files dns
...

The dns entry is vital. It tells Linux to use an external name server.
Normally, these entries are automatically managed by YaST, but
it would be prudent to check.

If all the relevant entries on the host are correct, let your system
administrator check the DNS server configuration for the correct
zone information. For detailed information about DNS, refer to
Chapter 25, The Domain Name System (↑Reference). If you have
made sure that the DNS configuration of your host and the DNS
server are correct, proceed with checking the configuration of
your network and network device.

4c If your system cannot establish a connection to a network server and
you have excluded name service problems from the list of possible
culprits, check the configuration of your network card.

Use the command ifconfig network_device (executed as
root) to check whether this device was properly configured. Make
sure that both inet address and Mask are configured correctly. An
error in the IP address or a missing bit in your network mask would
render your network configuration unusable. If necessary, perform
this check on the server as well.

4d If the name service and network hardware are properly
configured and running, but some external network connections
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still get long time-outs or fail entirely, use traceroute

fully_qualified_domain_name (executed as root) to track
the network route these requests are taking. This command lists any
gateway (hop) that a request from your machine passes on its way
to its destination. It lists the response time of each hop and whether
this hop is reachable at all. Use a combination of traceroute and ping
to track down the culprit and let the administrators know.

Once you have identified the cause of your network trouble, you can resolve it yourself
(if the problem is located on your machine) or let the system administrators of your
network know about your findings so they can reconfigure the services or repair the
necessary systems.

NetworkManager Problems

If you have a problem with network connectivity, narrow it down as described in
Procedure A.6, “How to Identify Network Problems” (page 100). If NetworkManager
seems to be the culprit, proceed as follows to get logs providing hints on why
NetworkManager fails:

1 Open a shell and log in as root.

2 Restart the NetworkManager:

rcnetwork restart -o nm

3 Open a web page, for example, http://www.opensuse.org  as normal
user to see, if you can connect.

4 Collect any information about the state of NetworkManager in /var/log/
NetworkManager .

For more information about NetworkManager, refer to Chapter 35, Using
NetworkManager (↑Reference).

A.2.6 Data Problems

Data problems are when the machine may or may not boot properly but, in either case,
it is clear that there is data corruption on the system and that the system needs to
be recovered. These situations call for a backup of your critical data, enabling you
to recover the system state from before your system failed. offers dedicated YaST
modules for system backup and restoration as well as a rescue system that can be
used to recover a corrupted system from the outside.

Managing Partition Images

Sometimes you need to perform a backup from an entire partition or even hard disk.
Linux comes with the dd tool which can create an exact copy of your disk. Combined
with gzip you save some space.

http://www.opensuse.org
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Procedure A.7 Backing up and Restoring Harddisks

1 Start a Shell as user root.

2 Select your source device. Typically this is something like /dev/sda  (labeled
as SOURCE).

3 Decide where you want to store your image (labeled as BACKUP_PATH). It must
be different from your source device. In other words: if you make a backup from
/dev/sda , your image file must not be stored under /dev/sda .

4 Run the commands to create a compressed image file:

dd if=/dev/SOURCE | gzip > /BACKUP_PATH/image.gz 

5 Restore the hard disk with the following commands:

gzip -dc /BACKUP_PATH/image.gz | dd of=/dev/SOURCE

If you only need a partition to backup, replace the SOURCE placeholder with your
respective partition. In this case, your image file can lie on the same hard disk, but on
a different partition.

Backing Up Critical Data

System backups can be easily managed using the YaST System Backup module:

1 As root, start YaST and select System > System Backup.

2 Create a backup profile holding all details needed for the backup, filename of
the archive file, scope, and type of the backup:

2a Select Profile Management > Add.

2b Enter a name for the archive.

2c Enter the path to the location of the backup if you want to keep a local
backup. For your backup to be archived on a network server (via
NFS), enter the IP address or name of the server and the directory
that should hold your archive.

2d Determine the archive type and click Next.

2e Determine the backup options to use, such as whether files not
belonging to any package should be backed up and whether a list of
files should be displayed prior to creating the archive. Also determine
whether changed files should be identified using the time-consuming
MD5 mechanism.

Use Expert to enter a dialog for the backup of entire hard disk areas.
Currently, this option only applies to the Ext2 file system.
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2f Finally, set the search constraints to exclude certain system areas
from the backup area that do not need to be backed up, such as lock
files or cache files. Add, edit, or delete items until your needs are
met and leave with OK.

3 Once you have finished the profile settings, you can start the backup right away
with Create Backup or configure automatic backup. It is also possible to create
other profiles tailored for various other purposes.

To configure automatic backup for a given profile, proceed as follows:

1 Select Automatic Backup from the Profile Management menu.

2 Select Start Backup Automatically.

3 Determine the backup frequency. Choose daily, weekly, or monthly.

4 Determine the backup start time. These settings depend on the backup
frequency selected.

5 Decide whether to keep old backups and how many should be kept. To receive
an automatically generated status message of the backup process, check Send
Summary Mail to User root.

6 Click OK to apply your settings and have the first backup start at the time
specified.

Restoring a System Backup

Use the YaST System Restoration module to restore the system configuration from a
backup. Restore the entire backup or select specific components that were corrupted
and need to be reset to their old state.

1 Start YaST > System > System Restoration.

2 Enter the location of the backup file. This could be a local file, a network mounted
file, or a file on a removable device, such as a floppy or a DVD. Then click Next.

The following dialog displays a summary of the archive properties, such as the
filename, date of creation, type of backup, and optional comments.

3 Review the archived content by clicking Archive Content. Clicking OK returns
you to the Archive Properties dialog.

4 Expert Options opens a dialog in which to fine-tune the restore process. Return
to the Archive Properties dialog by clicking OK.

5 Click Next to open the view of packages to restore. Press Accept to restore
all files in the archive or use the various Select All, Deselect All, and Select
Files buttons to fine-tune your selection. Only use the Restore RPM Database
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option if the RPM database is corrupted or deleted and this file is included in
the backup.

6 After you click Accept, the backup is restored. Click Finish to leave the module
after the restore process is completed.

A.2.7 Recovering a Corrupted System
There are several reasons why a system could fail to come up and run properly.
A corrupted file system following a system crash, corrupted configuration files, or a
corrupted boot loader configuration are the most common ones.

Using the Rescue System

contains a rescue system. The rescue system is a small Linux system that can be
loaded into a RAM disk and mounted as root file system, allowing you to access your
Linux partitions from the outside. Using the rescue system, you can recover or modify
any important aspect of your system:

• Manipulate any type of configuration file.

• Check the file system for defects and start automatic repair processes.

• Access the installed system in a “change root” environment.

• Check, modify, and reinstall the boot loader configuration.

• Resize partitions using the parted command. Find more information about
this tool at the GNU Parted website http://www.gnu.org/software/
parted/parted.html .

The rescue system can be loaded from various sources and locations. The simplest
option is to boot the rescue system from the original installation medium:

1 Insert the installation medium into your DVD drive.

2 Reboot the system.

3 At the boot screen, press [F4] and choose DVD-ROM. Then choose Rescue
System from the main menu.

4 Enter root at the Rescue: prompt. A password is not required.

If your hardware setup does not include a DVD drive, you can boot the rescue system
from a network source (including the openSUSE FTP server). The following example
applies to a remote boot scenario—if using another boot medium, such as a DVD,
modify the info file accordingly and boot as you would for a normal installation.

1 Enter the configuration of your PXE boot setup and add the lines
install=protocol://instsource and rescue=1. If you need to start the

http://www.gnu.org/software/parted/parted.html
http://www.gnu.org/software/parted/parted.html
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repair system, use repair=1 instead. As with a normal installation, protocol
stands for any of the supported network protocols (NFS, HTTP, FTP, etc.) and
instsource for the path to your network installation source.

2 Boot the system using “Wake on LAN”, as described in Section “Wake on
LAN” (Chapter 2, Remote Installation, ↑Reference).

3 Enter root at the Rescue: prompt. A password is not required.

Once you have entered the rescue system, you can make use of the virtual consoles
that can be reached with [Alt] + [F1] to [Alt] + [F6].

A shell and many other useful utilities, such as the mount program, are available in
the /bin directory. The sbin directory contains important file and network utilities for
reviewing and repairing the file system. This directory also contains the most important
binaries for system maintenance, such as fdisk, mkfs, mkswap, mount, mount, init, and
shutdown, and ifconfig, ip, route, and netstat for maintaining the network. The directory
/usr/bin  contains the vi editor, find, less, and ssh.

To see the system messages, either use the command dmesg or view the file /var/
log/messages .

Checking and Manipulating Configuration Files

As an example for a configuration that might be fixed using the rescue system, imagine
you have a broken configuration file that prevents the system from booting properly.
You can fix this using the rescue system.

To manipulate a configuration file, proceed as follows:

1 Start the rescue system using one of the methods described above.

2 To mount a root file system located under /dev/sda6  to the rescue system,
use the following command:

mount /dev/sda6 /mnt

All directories of the system are now located under /mnt

3 Change the directory to the mounted root file system:

cd /mnt

4 Open the problematic configuration file in the vi editor. Adjust and save the
configuration.

5 Unmount the root file system from the rescue system:

umount /mnt

6 Reboot the machine.
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Repairing and Checking File Systems

Generally, file systems cannot be repaired on a running system. If you encounter
serious problems, you may not even be able to mount your root file system and the
system boot may end with a “kernel panic”. In this case, the only way is to repair the
system from the outside. The rescue system provides all tools needed for a manual
file system check or repair. It contains the utilities to check and repair the ext2, ext3,
ext4, reiserfs, xfs, dosfs, and vfat file systems.

Accessing the Installed System

If you need to access the installed system from the rescue system to, you need to do
this in a change root environment. For example, to modify the boot loader configuration,
or to execute a hardware configuration utility.

To set up a change root environment based on the installed system, proceed as follows:

1 First mount the root partition from the installed system and the device file system
(change the device name to your current settings):

mount /dev/sda6 /mnt
mount --bind /dev /mnt/dev

2 Now you can “change root” into the new environment:

chroot /mnt

3 Then mount /proc and /sys:

mount /proc
mount /sys

4 Finally, mount the remaining partitions from the installed system:

mount -a

5 Now you have access to the installed system. Before rebooting the system,
unmount the partitions with umount -a and leave the “change root”
environment with exit.

WARNING: Limitations

Although you have full access to the files and applications of the installed system,
there are some limitations. The kernel that is running is the one that was booted with
the rescue system, not with the change root environment. It only supports essential
hardware and it is not possible to add kernel modules from the installed system
unless the kernel versions are exactly the same (which is unlikely). So you cannot
access a sound card, for example. It is also not possible to start a graphical user
interface.

Also note that you leave the “change root” environment when you switch the console
with [Alt] + [F1] to [Alt] + [F6].
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Modifying and Reinstalling the Boot Loader

Sometimes a system cannot boot because the boot loader configuration is corrupted.
The start-up routines cannot, for example, translate physical drives to the actual
locations in the Linux file system without a working boot loader.

To check the boot loader configuration and reinstall the boot loader, proceed as follows:

1 Perform the necessary steps to access the installed system as described in
Section “Accessing the Installed System” (page 108).

2 Check whether the following files are correctly configured according to the
GRUB configuration principles outlined in Chapter 18, The Boot Loader GRUB
(↑Reference) and apply fixes if necessary.

• /etc/grub.conf

• /boot/grub/device.map

• /boot/grub/menu.lst

• /etc/sysconfig/bootloader

3 Reinstall the boot loader using the following command sequence:

grub --batch < /etc/grub.conf

4 Unmount the partitions, log out from the “change root” environment, and reboot
the system:

umount -a
exit
reboot

A.3 Legal Notice
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LINUX Products GmbH, the authors, nor the translators shall be held liable for possible
errors or the consequences thereof.

GNU Free Documentation License

Version 1.2, November 2002

Copyright (C) 2000,2001,2002 Free Software Foundation, Inc. 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA

Everyone is permitted to copy and distribute verbatim copies of this license document, but changing it is not allowed.

PREAMBLE

The purpose of this License is to make a manual, textbook, or other functional and useful document “free” in the sense of freedom: to assure everyone
the effective freedom to copy and redistribute it, with or without modifying it, either commercially or noncommercially. Secondarily, this License preserves
for the author and publisher a way to get credit for their work, while not being considered responsible for modifications made by others.

This License is a kind of “copyleft”, which means that derivative works of the document must themselves be free in the same sense. It complements
the GNU General Public License, which is a copyleft license designed for free software.

We have designed this License in order to use it for manuals for free software, because free software needs free documentation: a free program should
come with manuals providing the same freedoms that the software does. But this License is not limited to software manuals; it can be used for any
textual work, regardless of subject matter or whether it is published as a printed book. We recommend this License principally for works whose purpose
is instruction or reference.

APPLICABILITY AND DEFINITIONS

This License applies to any manual or other work, in any medium, that contains a notice placed by the copyright holder saying it can be distributed
under the terms of this License. Such a notice grants a world-wide, royalty-free license, unlimited in duration, to use that work under the conditions
stated herein. The “Document”, below, refers to any such manual or work. Any member of the public is a licensee, and is addressed as “you”. You
accept the license if you copy, modify or distribute the work in a way requiring permission under copyright law.

A “Modified Version” of the Document means any work containing the Document or a portion of it, either copied verbatim, or with modifications and/
or translated into another language.

A “Secondary Section” is a named appendix or a front-matter section of the Document that deals exclusively with the relationship of the publishers or
authors of the Document to the Document’s overall subject (or to related matters) and contains nothing that could fall directly within that overall subject.
(Thus, if the Document is in part a textbook of mathematics, a Secondary Section may not explain any mathematics.) The relationship could be a matter
of historical connection with the subject or with related matters, or of legal, commercial, philosophical, ethical or political position regarding them.

The “Invariant Sections” are certain Secondary Sections whose titles are designated, as being those of Invariant Sections, in the notice that says that
the Document is released under this License. If a section does not fit the above definition of Secondary then it is not allowed to be designated as
Invariant. The Document may contain zero Invariant Sections. If the Document does not identify any Invariant Sections then there are none.

The “Cover Texts” are certain short passages of text that are listed, as Front-Cover Texts or Back-Cover Texts, in the notice that says that the Document
is released under this License. A Front-Cover Text may be at most 5 words, and a Back-Cover Text may be at most 25 words.

A “Transparent” copy of the Document means a machine-readable copy, represented in a format whose specification is available to the general public,
that is suitable for revising the document straightforwardly with generic text editors or (for images composed of pixels) generic paint programs or (for
drawings) some widely available drawing editor, and that is suitable for input to text formatters or for automatic translation to a variety of formats suitable
for input to text formatters. A copy made in an otherwise Transparent file format whose markup, or absence of markup, has been arranged to thwart
or discourage subsequent modification by readers is not Transparent. An image format is not Transparent if used for any substantial amount of text.
A copy that is not “Transparent” is called “Opaque”.

Examples of suitable formats for Transparent copies include plain ASCII without markup, Texinfo input format, LaTeX input format, SGML or XML using
a publicly available DTD, and standard-conforming simple HTML, PostScript or PDF designed for human modification. Examples of transparent image
formats include PNG, XCF and JPG. Opaque formats include proprietary formats that can be read and edited only by proprietary word processors,
SGML or XML for which the DTD and/or processing tools are not generally available, and the machine-generated HTML, PostScript or PDF produced
by some word processors for output purposes only.

The “Title Page” means, for a printed book, the title page itself, plus such following pages as are needed to hold, legibly, the material this License
requires to appear in the title page. For works in formats which do not have any title page as such, “Title Page” means the text near the most prominent
appearance of the work’s title, preceding the beginning of the body of the text.

A section “Entitled XYZ” means a named subunit of the Document whose title either is precisely XYZ or contains XYZ in parentheses following text
that translates XYZ in another language. (Here XYZ stands for a specific section name mentioned below, such as “Acknowledgements”, “Dedications”,
“Endorsements”, or “History”.) To “Preserve the Title” of such a section when you modify the Document means that it remains a section “Entitled XYZ”
according to this definition.

The Document may include Warranty Disclaimers next to the notice which states that this License applies to the Document. These Warranty Disclaimers
are considered to be included by reference in this License, but only as regards disclaiming warranties: any other implication that these Warranty
Disclaimers may have is void and has no effect on the meaning of this License.

VERBATIM COPYING

You may copy and distribute the Document in any medium, either commercially or noncommercially, provided that this License, the copyright notices,
and the license notice saying this License applies to the Document are reproduced in all copies, and that you add no other conditions whatsoever to
those of this License. You may not use technical measures to obstruct or control the reading or further copying of the copies you make or distribute.
However, you may accept compensation in exchange for copies. If you distribute a large enough number of copies you must also follow the conditions
in section 3.

You may also lend copies, under the same conditions stated above, and you may publicly display copies.

COPYING IN QUANTITY

If you publish printed copies (or copies in media that commonly have printed covers) of the Document, numbering more than 100, and the Document’s
license notice requires Cover Texts, you must enclose the copies in covers that carry, clearly and legibly, all these Cover Texts: Front-Cover Texts on
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the front cover, and Back-Cover Texts on the back cover. Both covers must also clearly and legibly identify you as the publisher of these copies. The
front cover must present the full title with all words of the title equally prominent and visible. You may add other material on the covers in addition.
Copying with changes limited to the covers, as long as they preserve the title of the Document and satisfy these conditions, can be treated as verbatim
copying in other respects.

If the required texts for either cover are too voluminous to fit legibly, you should put the first ones listed (as many as fit reasonably) on the actual cover,
and continue the rest onto adjacent pages.

If you publish or distribute Opaque copies of the Document numbering more than 100, you must either include a machine-readable Transparent copy
along with each Opaque copy, or state in or with each Opaque copy a computer-network location from which the general network-using public has
access to download using public-standard network protocols a complete Transparent copy of the Document, free of added material. If you use the latter
option, you must take reasonably prudent steps, when you begin distribution of Opaque copies in quantity, to ensure that this Transparent copy will
remain thus accessible at the stated location until at least one year after the last time you distribute an Opaque copy (directly or through your agents
or retailers) of that edition to the public.

It is requested, but not required, that you contact the authors of the Document well before redistributing any large number of copies, to give them a
chance to provide you with an updated version of the Document.

MODIFICATIONS

You may copy and distribute a Modified Version of the Document under the conditions of sections 2 and 3 above, provided that you release the Modified
Version under precisely this License, with the Modified Version filling the role of the Document, thus licensing distribution and modification of the Modified
Version to whoever possesses a copy of it. In addition, you must do these things in the Modified Version:

A.  Use in the Title Page (and on the covers, if any) a title distinct from that of the Document, and from those of previous versions (which should, if
there were any, be listed in the History section of the Document). You may use the same title as a previous version if the original publisher of that
version gives permission.

B.  List on the Title Page, as authors, one or more persons or entities responsible for authorship of the modifications in the Modified Version, together with
at least five of the principal authors of the Document (all of its principal authors, if it has fewer than five), unless they release you from this requirement.

C.  State on the Title page the name of the publisher of the Modified Version, as the publisher.

D.  Preserve all the copyright notices of the Document.

E.  Add an appropriate copyright notice for your modifications adjacent to the other copyright notices.

F.  Include, immediately after the copyright notices, a license notice giving the public permission to use the Modified Version under the terms of this
License, in the form shown in the Addendum below.

G.  Preserve in that license notice the full lists of Invariant Sections and required Cover Texts given in the Document’s license notice.

H.  Include an unaltered copy of this License.

I.  Preserve the section Entitled “History”, Preserve its Title, and add to it an item stating at least the title, year, new authors, and publisher of the
Modified Version as given on the Title Page. If there is no section Entitled “History” in the Document, create one stating the title, year, authors, and
publisher of the Document as given on its Title Page, then add an item describing the Modified Version as stated in the previous sentence.

J.  Preserve the network location, if any, given in the Document for public access to a Transparent copy of the Document, and likewise the network
locations given in the Document for previous versions it was based on. These may be placed in the “History” section. You may omit a network location
for a work that was published at least four years before the Document itself, or if the original publisher of the version it refers to gives permission.

K.  For any section Entitled “Acknowledgements” or “Dedications”, Preserve the Title of the section, and preserve in the section all the substance and
tone of each of the contributor acknowledgements and/or dedications given therein.

L.  Preserve all the Invariant Sections of the Document, unaltered in their text and in their titles. Section numbers or the equivalent are not considered
part of the section titles.

M.  Delete any section Entitled “Endorsements”. Such a section may not be included in the Modified Version.

N.  Do not retitle any existing section to be Entitled “Endorsements” or to conflict in title with any Invariant Section.

O.  Preserve any Warranty Disclaimers.

If the Modified Version includes new front-matter sections or appendices that qualify as Secondary Sections and contain no material copied from the
Document, you may at your option designate some or all of these sections as invariant. To do this, add their titles to the list of Invariant Sections in the
Modified Version’s license notice. These titles must be distinct from any other section titles.

You may add a section Entitled “Endorsements”, provided it contains nothing but endorsements of your Modified Version by various parties--for example,
statements of peer review or that the text has been approved by an organization as the authoritative definition of a standard.

You may add a passage of up to five words as a Front-Cover Text, and a passage of up to 25 words as a Back-Cover Text, to the end of the list of
Cover Texts in the Modified Version. Only one passage of Front-Cover Text and one of Back-Cover Text may be added by (or through arrangements
made by) any one entity. If the Document already includes a cover text for the same cover, previously added by you or by arrangement made by the
same entity you are acting on behalf of, you may not add another; but you may replace the old one, on explicit permission from the previous publisher
that added the old one.

The author(s) and publisher(s) of the Document do not by this License give permission to use their names for publicity for or to assert or imply
endorsement of any Modified Version.

COMBINING DOCUMENTS

You may combine the Document with other documents released under this License, under the terms defined in section 4 above for modified versions,
provided that you include in the combination all of the Invariant Sections of all of the original documents, unmodified, and list them all as Invariant
Sections of your combined work in its license notice, and that you preserve all their Warranty Disclaimers.

The combined work need only contain one copy of this License, and multiple identical Invariant Sections may be replaced with a single copy. If there
are multiple Invariant Sections with the same name but different contents, make the title of each such section unique by adding at the end of it, in
parentheses, the name of the original author or publisher of that section if known, or else a unique number. Make the same adjustment to the section
titles in the list of Invariant Sections in the license notice of the combined work.
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In the combination, you must combine any sections Entitled “History” in the various original documents, forming one section Entitled “History”; likewise
combine any sections Entitled “Acknowledgements”, and any sections Entitled “Dedications”. You must delete all sections Entitled “Endorsements”.

COLLECTIONS OF DOCUMENTS

You may make a collection consisting of the Document and other documents released under this License, and replace the individual copies of this
License in the various documents with a single copy that is included in the collection, provided that you follow the rules of this License for verbatim
copying of each of the documents in all other respects.

You may extract a single document from such a collection, and distribute it individually under this License, provided you insert a copy of this License
into the extracted document, and follow this License in all other respects regarding verbatim copying of that document.

AGGREGATION WITH INDEPENDENT WORKS

A compilation of the Document or its derivatives with other separate and independent documents or works, in or on a volume of a storage or distribution
medium, is called an “aggregate” if the copyright resulting from the compilation is not used to limit the legal rights of the compilation’s users beyond
what the individual works permit. When the Document is included in an aggregate, this License does not apply to the other works in the aggregate
which are not themselves derivative works of the Document.

If the Cover Text requirement of section 3 is applicable to these copies of the Document, then if the Document is less than one half of the entire
aggregate, the Document’s Cover Texts may be placed on covers that bracket the Document within the aggregate, or the electronic equivalent of covers
if the Document is in electronic form. Otherwise they must appear on printed covers that bracket the whole aggregate.

TRANSLATION

Translation is considered a kind of modification, so you may distribute translations of the Document under the terms of section 4. Replacing Invariant
Sections with translations requires special permission from their copyright holders, but you may include translations of some or all Invariant Sections in
addition to the original versions of these Invariant Sections. You may include a translation of this License, and all the license notices in the Document,
and any Warranty Disclaimers, provided that you also include the original English version of this License and the original versions of those notices and
disclaimers. In case of a disagreement between the translation and the original version of this License or a notice or disclaimer, the original version
will prevail.

If a section in the Document is Entitled “Acknowledgements”, “Dedications”, or “History”, the requirement (section 4) to Preserve its Title (section 1)
will typically require changing the actual title.

TERMINATION

You may not copy, modify, sublicense, or distribute the Document except as expressly provided for under this License. Any other attempt to copy, modify,
sublicense or distribute the Document is void, and will automatically terminate your rights under this License. However, parties who have received
copies, or rights, from you under this License will not have their licenses terminated so long as such parties remain in full compliance.

FUTURE REVISIONS OF THIS LICENSE

The Free Software Foundation may publish new, revised versions of the GNU Free Documentation License from time to time. Such new versions will
be similar in spirit to the present version, but may differ in detail to address new problems or concerns. See http://www.gnu.org/copyleft/.

Each version of the License is given a distinguishing version number. If the Document specifies that a particular numbered version of this License “or
any later version” applies to it, you have the option of following the terms and conditions either of that specified version or of any later version that has
been published (not as a draft) by the Free Software Foundation. If the Document does not specify a version number of this License, you may choose
any version ever published (not as a draft) by the Free Software Foundation.

ADDENDUM: How to use this License for your documents

To use this License in a document you have written, include a copy of the License in the document and put the following copyright and license notices
just after the title page:

   Copyright (c) YEAR YOUR NAME.
   Permission is granted to copy, distribute and/or modify this document
   under the terms of the GNU Free Documentation License, Version 1.2
   or any later version published by the Free Software Foundation;
   with no Invariant Sections, no Front-Cover Texts, and no Back-Cover Texts.
   A copy of the license is included in the section entitled “GNU
   Free Documentation License”.
  

If you have Invariant Sections, Front-Cover Texts and Back-Cover Texts, replace the “with...Texts.” line with this:

   with the Invariant Sections being LIST THEIR TITLES, with the
   Front-Cover Texts being LIST, and with the Back-Cover Texts being LIST.
  

If you have Invariant Sections without Cover Texts, or some other combination of the three, merge those two alternatives to suit the situation.

If your document contains nontrivial examples of program code, we recommend releasing these examples in parallel under your choice of free software
license, such as the GNU General Public License, to permit their use in free software.
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